ќбсудим вашу задачу в Telegram - чате?

ћерион Ќетворкс

ѕривет! —егодн€ в статье мы рассмотрим базовую настройку IP-ј“— компании Cisco Ц CME Ц Call Manager Express, или как теперь он называемс€ Cisco Unified Communications Manager Express Ц CUCME. “акже мы покажем как зарегистрировать телефоны, работающие по протоколам SCCP и SIP.

„тобы пон€ть, что необходимо настроить, рассмотрим, что происходит во врем€ загрузки телефона. ѕроцесс загрузки IP-телефона Cisco можно разделить на несколько этапов:

  1. “елефон получает питание по Ethernet кабелю использу€ PoE (Power over Ethernet 802.3af), либо через блок питани€;
  2.  оммутатор присылает информацию о голосовом VLANТe, использу€ протокол CDP (Cisco Discovery Protocol);
  3. “елефон высылает DHCP запрос в голосовой VLAN, а в ответ DHCP сервер присылает информацию о IP адресации, включа€ DHCP Option 150, где указан адрес TFTP сервера;
  4. “елефон св€зываетс€ с TFTP сервером и скачивает конфигурационный файл и прошивку. ¬ конфигурационном файле наход€тс€ данные об адресе и номере порта CME, а также название прошивки, которую он должен использовать. ѕри первом подключении он отсутствует, и телефон скачивает файл по умолчанию XMLDefault.cnf.xml;
  5. Ќа основании IP адреса, указанного в конфигурационном файле телефон св€зываетс€ с сервером обработки вызовов (в нашем случае это CME);

“еперь можем приступать к настройке оборудовани€.


Ќастройка voice VLAN

„тобы разделить голосовой трафик и трафик с данными необходимо настроить голосовой VLAN на каждом порту коммутатора, который соедин€етс€ с IP телефонами.

switch#conf t Ц переход в режим конфигурации
switch(config)#interface fa0/1 Ц переход в режим конфигурации интерфейса
switch(config-if)#switchport mode access Ц настройка порта в качестве access 
switch(config-if)#switchport voice vlan 100 Ц создание голосового VLAN  с id 100
switch(config-if)#switchport access vlan 200 Ц создание VLAN данных с id 200
switch(config-if)#spanning-tree portfast Ц включение протокола STP

Ќастройка DHCP

“еперь необходимо настроить роутер Cisco как DHCP сервер дл€ голосового VLAN.  оманда Option 150 используетс€ дл€ указани€ адреса TFTP сервера, где хран€тс€ конфигурационные файлы и прошивки.

router#ip dhcp pool VOICE Ц создание DHCP пула
router(dhcp-config)#network 192.168.1.0 255.255.255.0 Ц выделение подсети 
router(dhcp-config)#default-router 192.168.1.1 Ц default gateway
router(dhcp-config)#option 150 192.168.1.1 Ц адрес TFTP сервера
router(dhcp-config)#dns-server 4.2.2.2 Ц адрес DNS сервера

Ќастройка NTP

ѕерейдем к настойке времени c использованием протокола NTP, при помощи которого мы сможем выставить корректные дату и врем€ на всех телефонах.

router#conf t
router(config)#ntp server 64.209.210.20 Ц указываем адрес NTP сервера
router(config)#clock timezone MSK 3 Ц указываем временную зону 

Ќастройка TFTP

’от€ маршрутизаторы Cisco можно использовать в качестве TFTP сервера, стоит заметить что дл€ больших телефонных сетей лучше иметь отдельный TFTP сервер, поскольку файлы прошивки и конфигурации могут быстро заполнить всю доступную flash-пам€ть.

ѕри использовании маршрутизатора в роли TFTP сервера необходимо вручную указать все файлы дл€ скачивани€, которые мы поместили во flash-пам€ти.

¬ нашем примере файлы наход€тс€ в папке phone/7940-7960/

router#conf t
router(config)#tftp-server flash:/phone/7940-7960/P00308000500.bin alias P00308000500.bin
router(config)#tftp-server flash:/phone/7940-7960/P00308000500.loads alias P00308000500.loads
router(config)#tftp-server flash:/phone/7940-7960/P00308000500.sb2 alias P00308000500.sb2
router(config)#tftp-server flash:/phone/7940-7960/P00308000500.sbn alias P00308000500.sbn

«десь в команде tftp-server после alias указываем название файла прошивки, который будет запрашивать телефон, поскольку телефон не знает полный путь до файла, а запрашивает его только по названию.


Ѕазовые настройки CME и регистраци€ телефонов

“еперь настроим необходимые параметры IP Source Address, Max-DN (Directory Number) и Max-Ephones дл€ работы с протоколом SCCP.

router(config)#telephony-service Ц режим настройки телефонии
router(config-telepony)#ip source-address 192.168.1.1 Ц адрес, на который должны приходить запросы на регистрацию от телефонов
router(config-telepony)#max-ephones 24 Ц максимальное количество поддерживаемых телефонов
router(config-telepony)#max-dn 48 Ц максимальное количество поддерживаемых номеров

ѕараметры max-ephones и max-dn напр€мую вли€ют на объем пам€ти, которую резервирует маршрутизатор дл€ поддержки службы CME. ѕри установке значени€ намного выше, чем необходимо, система может резервировать чрезмерные ресурсы и вли€ть на другие сетевые службы.  роме того, параметр max-ephones не должен превышать количество приобретенных лицензий на функции.

ѕосле этого телефоны начнут процесс регистрации. ѕроверить статус регистрации можно командой show ephone summary


Ќастройка Ephone и Ephone-DN

ƒл€ начала попробуем разобратьс€, что это такое и в чем их отличие. Ephone можно представить в качестве физического телефона с MAC адресом, а Ephone-DN в качестве телефонного номера, который мы св€зываем с телефонным аппаратом.

—оздадим номер Ephone-DN с номером 101:

router#conf t
router(config)#ephone-dn 1 Ц создание номера
router(config-ephone-dn)#number 101 Ц указываем номер
router(config-ephone-dn)#description Alexey Dobronravov Ц описание в CME
router(config-ephone-dn)#name Alexey Dobronravov Ц описание на телефоне

“еперь создадим Ephone и св€жем его с реальным телефоном по MAC-адресу:

router#conf t
router(config)#ephone 1 Ц создание образа телефона
router(config-ephone)#mac-address 0014.1c48.acb1 Ц указываем MAC-адрес
router(config-ephone)#button 1:1 Ц прив€зываем номер к аппарату

ћы прив€зываем номер к телефону на его физические кнопки, которые обычно наход€тс€ возле экрана. Ќа них как раз можно прив€зывать линии, и телефон может одновременно несколько номеров. —интаксис команды через которую идет прив€зка телефона выгл€дит как button [физическа€ кнопка] : [ephone-dn] . “аким образом, в примере мы прив€зали первой кнопке на телефоне созданный нами номер ephone-dn 1.

“еперь можем подключать наш телефон к сети, он пройдет все шаги загрузки и зарегистрируетс€ на нашем CME. “аким же образом настраиваем другие телефоны и номера, после чего мы сможем совершать звонки между телефонами. ѕроверить статус телефона можно командой show ephone.


–егистраци€ SIP телефона

“еперь настроим CME дл€ работы с телефонами по протоколу SIP. ѕервым делом разрешим звонки между SIP телефонами:

router#conf t
router(config)#voice service voip
router(config-voice)#allow-connections sip to sip

Ќастраиваем период регистрации телефонов (число Ц это врем€ в секундах, по умолчанию 3600):

router#conf t
router(config)#voice service voip
router(config-voice)#registrar server expires max 3600 min 3600

—оздаем класс кодеков, в котором указываем кодеки, которые будут использованы:

router#conf t
router(config)#voice class codec 1 
router(config-voice)#codec preference 1 g711alaw  - кодек первого приоритета
router(config-voice)#codec preference 1 g711ulaw  - кодек второго приоритета
router(config-voice)#codec preference 1 g729br8 - кодек третьего приоритета

—оздаем DN:

router#conf t
router(config)#voice register dn 1 Ц создаем DN
router(config-voice-register-dn)#number 201 Ц указываем номер

Ќастраиваем телефон:

router#conf t
router(config)#voice register pool 1
router(config-voice-register-pool)#id mac 0014.1c48.acb2 Ц указываем MAC телефона
router(config-voice-register-pool)#number 1 dn 1 Ц прив€зываем номер к первой линии
router(config-voice-register-pool)#voice-class codec 1 Ц используем созданный нами набор кодеков
router(config-voice-register-pool)#username admin password pass Ц создаем аутентификационные данные

ѕосле этого подключаем SIP телефон к сети и заходим по его веб-интерфейс черз бразуер по IP-адресу, находим настройки первой линии, где указываем адрес сервера 192.168.1.1 и логин с паролем admin/password, которые мы создали.

“еперь таким образом можно регистрировать SIP телефоны на CME.


ѕолезна ли ¬ам эта стать€?