Telegram - ?

Cisco .

, . , BGP, .

, IPv4 , IPv4 . , , WAN NAT . , .


.

BGP , , , , . .

WAN (ISP1 ISP2 ). .

Cisco 891-K9 WAN IOS c880data-universalk9-mz.153-3.M2.bin

:

interface GigabitEthernet0 
description Internet_ISP1_Main
ip address 10.10.10.10 255.255.255.0
no ip proxy-arp
ip nat outside // NAT    
interface FastEthernet8
description Internet_ISP2_Back-up
ip address 100.100.100.100 255.255.255.0
no ip proxy-arp
ip nat outside // NAT   
interface Vlan1
description Local_Area_Network 
ip address 192.168.1.1 255.255.255.0
ip nat inside //    NAT

ACL ( ) :

ip access-list extended NAT_LAN
permit ip 192.168.1.0 0.0.0.255 any

, :

route-map NAT_ISP1_Main permit 10
match ip address NAT_LAN //    ACL    
match interface GigabitEthernet0 //   WAN 
!
route-map NAT_ISP2_Back-up permit 10
match ip address NAT_LAN //    ACL    network
match interface FastEthernet8 //   WAN 

SLA :

ip sla 1
 icmp-echo 8.8.8.8  source-interface GigabitEthernet0 // DNS    
frequency 30 //    30 
ip sla schedule 1 life forever start-time now //SLA  
track 1 ip sla 1 //      IPSLA1

:

ip route 0.0.0.0 0.0.0.0 10.10.10.1 track 1
ip route 0.0.0.0 0.0.0.0 100.100.100.1 30

track 1 , . , 30.

NAT:

ip nat inside source route-map NAT_ISP1_Main  interface GigabitEthernet0  overload
ip nat inside source route-map NAT_ISP2_Back-up interface FastEthernet8   overload

?