img

Отказоустойчивость WAN на роутерах Cisco

В сегодняшней статье рассмотрим сценарий с настройкой отказоустойчивости на маршрутизаторе Cisco с использованием двух интернет провайдеров.

При случае аварии у вашего интернет оператора отказоустойчивость с использованием двух провайдеров является очень хорошей идеей, более того – иногда без этого не обойтись. Однако, в таком сценарии часто необходимо использовать протокол маршрутизации BGP, который довольно нелегок в настройке и предъявляет высокие требования к оборудованию.

В большинстве случаев, вам необходимы две выделенных IPv4 подсети – но учтите, что покупка IPv4 блока является довольно дорогостоящей затеей. Однако, есть альтернативное и более бюджетное решение – если вам не нужна целая подсеть от провайдера, у вас может быть основной и запасной WAN каналы и использовать NAT для обоих линков с автоматическим фэйловером. Данный сценарий будет работать только для сетей, у которых есть исходящий трафик.


Описание сценария и настройка

В примере ниже мы продемонстрируем стандартную топологию – данное решение задачи будет работать во многих сценариях.

Вы все еще можете использовать BGP соединение для каждого провайдера, который анонсирует дефолтный маршрут, однако, как правило, провайдеры делают это за отдельную плату. В данной топологии мы будем использовать два плавающих статических маршрутах.

На топологии ниже у нас есть два WAN соединения (ISP1 – основной линк и ISP2 – запасной линк). Нам просто необходимо предоставить доступ в интернет для нашей внутренней подсети.

Все настройки в данной статье были выполнены на маршрутизаторе Cisco 891-K9 с двумя WAN портами и IOS версии c880data-universalk9-mz.153-3.M2.bin
Топология сети

Настройка маршрутизатора

Сначала настраиваем интерфейсы:

interface GigabitEthernet0 
description Internet_ISP1_Main
ip address 10.10.10.10 255.255.255.0
no ip proxy-arp
ip nat outside //включаем NAT на первом интерфейсе 
interface FastEthernet8
description Internet_ISP2_Back-up
ip address 100.100.100.100 255.255.255.0
no ip proxy-arp
ip nat outside //включаем NAT на втором интерфейсе
interface Vlan1
description Local_Area_Network 
ip address 192.168.1.1 255.255.255.0
ip nat inside //весь сгенерированный трафик будет NATирован

Затем настраиваем ACL (лист контроля доступа) в соответствии с нашей внутренней подсетью:

ip access-list extended NAT_LAN
permit ip 192.168.1.0 0.0.0.255 any

Переходим к настройке маршрутных карт, которые будут выбирать какой трафик НАТировать на каждом интерфейсе:

route-map NAT_ISP1_Main permit 10
match ip address NAT_LAN //совпадение для настроенного прежде ACL с внутренней подсетью 
match interface GigabitEthernet0 //совпадение для первого WAN интерфейса
!
route-map NAT_ISP2_Back-up permit 10
match ip address NAT_LAN //совпадение для настроенного прежде ACL с внутренней подсетью network
match interface FastEthernet8 //совпадение для второго WAN интерфейса

Настраиваем отслеживание и SLA для замены канала в случае аварии:

ip sla 1
 icmp-echo 8.8.8.8  source-interface GigabitEthernet0 //пингуем DNS Гугла используя первый интерфейс
frequency 30 //пинги отправляются раз в 30 секунд
ip sla schedule 1 life forever start-time now //SLA респондер включен
track 1 ip sla 1 //“объект” для отслеживания создан с помощью IPSLA1

Добавляем маршруты по умолчанию:

ip route 0.0.0.0 0.0.0.0 10.10.10.1 track 1
ip route 0.0.0.0 0.0.0.0 100.100.100.1 30

Пока объект track 1 «поднят», первый маршрут будет указан в таблице маршрутизации. Если данный объект «упадет», то маршрут будет заменен на второй маршрут по умолчанию с метрикой 30.

Как заключительный шаг – включаем NAT:

ip nat inside source route-map NAT_ISP1_Main  interface GigabitEthernet0  overload
ip nat inside source route-map NAT_ISP2_Back-up interface FastEthernet8   overload
Ссылка
скопирована
Сети
Скидка 25%
Основы сетевых технологий
Стань сетевиком с нуля за 2 месяца. Веселая и дружелюбная подача информации с эмуляцией реальных задач.
Получи бесплатный
вводный урок!
Пожалуйста, укажите корректный e-mail
отправили вводный урок на твой e-mail!
Получи все материалы в telegram и ускорь обучение!
img
Еще по теме:
img
Задержка в сети, или сетевая задержка, - это временная задержка при передаче запросов или данных от источника к адресату в сетев
img
Система доменных имен (DNS – Domain Name System) обеспечивает сетевую коммуникацию. DNS может показаться какой-то невидимой сило
img
Wi-Fi это технология, которая использует радиоволны для отправки и получения сигналов от находящихся поблизости устройств, чтобы
img
BGP (Border Gateway Protocol) - это протокол граничного шлюза, предназначенный для обмена информацией о маршрутизации и доступно
img
Когда читаете данную статью, браузер подключается к провайдеру (или ISP) а пакеты, отправленные с компьютера, находят путь до се
img
Современные веб-сайты и приложения генерируют большой трафик и одновременно обслуживают многочисленные запросы клиентов. Баланси
Комментарии
ЛЕТНИЕ СКИДКИ
40%
50%
60%
До конца акции: 30 дней 24 : 59 : 59