35 IT - YouTube

4

Router-on-a-stick ( ) - , , , Ethernet, 802.1Q . 802.1Q , VLAN. VLAN VLAN (Inter-VLAN routing).

, , , , 3- .

lollypop. ?

 Li li li li lick me like a lollipop

, , , VoIP. VoIP , 3- , . VoIP, .

, VLAN , , , ( ).

, Cisco 802.1Q VLAN.

 Router-on-a-stick

1

VLAN Cisco IP-. Cisco VLAN1 (VLAN ), VLAN2.

Switch# configure terminal
Switch(config)# vlan2
Switch(config-vlan)# name voice
Switch(config-vlan)# exit
Switch(config)# interface vlan1
Switch(config-if)# ip address 192.168.10.2 255.255.255.0
Switch(config-if)# exit
Switch(config)# interface vlan2
Switch(config-if)# ip address 192.168.20.2 255.255.255.0
Switch(config-if)# exit

, , . GigabitEthernet 0/1

Switch# configure terminal
Switch(config)# interface gigabitethernet 0/1
Switch(config-if)# switchport trunk encapsulation dot1q
Switch(config-if)# switchport mode trunk
Switch(config-if)# spanning-tree portfast trunk

, 802.1Q, portfast trunk spanning-tree, , , , . : spanning-tree portfast trunk , , .


2

, VLAN .

, - , - (sub-interface) VLAN.

Router# configure terminal
Router(config)# interface gigabitethernet0/1
Router(config-if)# no ip address
Router(config-if)# duplex auto
Router(config-if)# speed auto
Router(config-if)# interface gigabitethernet0/1.1
Router(config-subif)# encapsulation dot1q 1 native
Router(config-subif)# ip address 192.168.10.1 255.255.255.0
Router(config-subif)# interface gigabitethernet0/1.2
Router(config-subif)# encapsulation dot1q 2
Router(config-subif)# ip address 192.168.20.1 255.255.255.0

, - VLAN, . - IP- 802.1Q VLAN, -.

, encapsulation dot1q 2 802.1Q - VLAN 2.

native - gigabitethernet0/1.1, , vlan - VLAN 1. Cisco .

show vlans, -, show ip route -.

! VLAN.


?