171 809 просмотров нашего канала на YouTube!

ћерион Ќетворкс

9 минут чтени€

 омпани€ Juniper €вл€етс€ очень крупным производителем сетевого оборудовани€ в мире - после Cisco and Huawei. ѕосле того как вы купили, установили и скоммутировали новое оборудование, возникает вопрос о его правильной настройке.

ѕреимуществом коммутаторов от производител€ Juniper, в основном, €вл€етс€ возможность объединени€ до шести коммутаторов в одно единое устройство с надежным и удобным управлением портами, сохран€€ стабильную и бесперебойную работу сети.

Juniper
  • Ќастройка сетевого интерфейса
  • Ќастройка QoS (качество обслуживани€)
  • Virtual Chassis (объединение коммутаторов)
  • –еализаци€ возможности сброса до заводских настроек

Ќастроив данные компоненты, вы сможете реализовать работу сети с использованием в ней большого количества устройств дл€ осуществлени€ передачи трафика.


Ќастройка сетевого интерфейса

»нтерфейс коммутатора отвечает за реализацию передачи данных между сетью и пользователем, что и €вл€етс€ главной задачей коммутатора. ≈го конфигураци€ осуществл€етс€ с помощью следующих строк кода:

root> configure
Entering configuration mode
[edit]
root# edit interfaces
[edit interfaces]
root#

 онфигураци€ L3:

[edit interfaces]
root# set em0 unit 0 family inet address 100.0.0.1/30

√де: Em0 - физический интерфейс, а Family inet - позвол€ет выбрать протокол интерфейса.  оманда "show" позволит из Configuration Mode проверить результат вашей настройки:

[edit interfaces]
root# show
em0 {
unit 0 {
family inet {
address 100.0.0.1/30;
}
}
}
[edit interfaces]

“еперь примените настройки с помощью следующей команды:

root# commit
commit complete

— помощью команды ping осуществим проверку конфигурации:

root> ping 100.0.0.2 rapid
PING 100.0.0.2 (100.0.0.2): 56 data bytes
!!!!!
--- 100.0.0.2 ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max/stddev = 0.402/0.719/1.306/0.343 ms

 онфигураци€ L2


root> configure
Entering configuration mode
[edit]
root# edit interfaces em0
[edit interfaces em0]

Ќеобходимо задать дуплекс на интерфейсе:

[edit interfaces em0]
root# set link-mode full-duplex
[edit interfaces em0]
root#

ѕримечание: L2 - устройства, работающие на канальном уровне, при этом коммутатором занимаетс€ фреймами. ј L3 взаимодействуют с IP-адресами и осуществл€ют маршрутизацию.  онфигураци€ L3 включает большее число параметров за счет расширенного функционала.

Juniper L3

Ќастройка Virtual Chassis

ѕосле правильной настройки интерфейса, следует перейти к объединению коммутаторов, которое позволит облегчить управление устройствами, а также повысить надежность работы сети, за счет взаимозамен€емости устройств. —ледует отметить, что коммутаторы Juniper не имеют отдельным порт VCP, поэтому придетс€ настраивать обычный интерфейс в качестве VCP.

Virtual Chassis
 онфигураци€ VCP вручную:

¬ключите все коммутаторы, также вам понадоб€тс€ их заводска€ маркировка, которую следует записать. ƒл€ примера используем следующие:

CT0216330172
CV0216450257

¬ключите коммутатор, который будет выполн€ть функцию master switch, после чего сделайте сброс настройка с помощью следующей строки кода:

request system zeroize

ѕерезагрузив систему, выполните следующие строки:

ezsetup
set system host-name sw_master
set system domain-name metholding.int
set system domain-search metholding.int
set system time-zone Europe/Moscow
set system root-authentication plain-text-password
set system name-server 10.10.6.26
set system name-server 10.10.6.28
set system services ssh protocol-version v2
set system ntp server 10.10.1.130 version 4
set system ntp server 10.10.1.130 prefer
set vlans Management description 10.10.45.0/24
set vlans Management vlan-id 100
set vlans Management l3-interface vlan.1
set interfaces vlan unit 1 family inet address 10.10.45.100/24
set routing-options static route 0.0.0.0/0 next-hop 10.10.45.1
set interfaces ge-0/0/47 unit 0 family ethernet-switching port-mode trunk
set interfaces ge-0/0/47 unit 0 family ethernet-switching vlan members Management

јктивируем preprovisioned configuration mode:

set virtual-chassis preprovisioned

¬носим серийные номера оборудовани€:

set virtual-chassis member 0 serial-number CT02/16330172 role routing-engine
set virtual-chassis member 1 serial-number CV0216450257 role routing-engine
set virtual-chassis no-split-detection

ѕроверьте результат, с помощью следующей строки:

root@sw-master> show virtual-chassis status

ќбнулите конфигурацию и включайте остальные коммутаторы:

request system zeroize

–аздел virtual-chassis в конфигурации должен быть пустой, а дл€ подстраховки, используйте команду:

delete virtual-chassis

Ќастроим порты VCP дл€ каждого коммутатора. ƒл€ данного примера, соедините коммутаторы портами ge-0/0/0 и ge-0/0/1 соответственно. “еперь задайте эти строки кода на каждом из коммутаторов:

request virtual-chassis vc-port set pic-slot 0 port 0
request virtual-chassis vc-port set pic-slot 0 port 1
--------------------¬џ¬ќƒ----------------------------
root> show interfaces terse
Interface Admin Link Proto Local Remote
vcp-255/0/0 up up
vcp-255/0/0.32768 up up
vcp-255/0/1 up up
vcp-255/0/1.32768 up up
ge-0/0/2 up down
ge-0/0/2.0 up down eth-switch

“еперь два коммутатора объединились, проверить можно с помощью команды:

show virtual-chassis status
show virtual-chassis vc-port

≈сли вы захотите добавить дополнительных участников к virtual-chassis, вам будет необходимо очистить конфигурацию нового коммутатора:

show interfaces terse | match vcp

≈сли есть, их надо удалить с командой:

request virtual-chassis vc-port delete pic-slot 0 port 0

¬несите серийный номер дополнительного устройства:

set virtual-chassis member 2 serial-number CT0217190258 role line-card

Ќастройка портов VCP в новом коммутаторе, в котором мы соедин€ем следующими портами - ge-0/0/0 и ge-0/0/1:

request virtual-chassis vc-port set pic-slot 0 port 0
request virtual-chassis vc-port set pic-slot 0 port 1

“еперь проверьте их наличие:

show interfaces terse | match vcp

ЌастройкаQoS

“ехнологи€ QoS используетс€ дл€ распределение используемого трафика и ранжирование на классы с различным приоритетом. “ехнологи€ необходима дл€ увеличени€ веро€тности пропускани€ трафика между точками в сети.

—ейчас мы рассмотрим деление потока трафика с приоритетом на ip-телефонию и видеоконференцсв€зь на коммутаторе и использованием настроек по умолчанию class-of-service (CoS).

ƒопустим, что ip-телефоны подключены к коммутатору, а дл€ маркировки ip-пакетов от ip-PBX и других ip-телефонов используютс€ следующие показани€ DSCP:

  • 46 - ef - медиа (RTP)
  • 24 - cs3 - сигнализаци€ (SIP, H323, Unistim)
  • 32 - cs4 - видео с кодеков (RTP)
  • 34 - af41 - видео с телефона, софтового клиента, кодека (RTP)
  • 0 - весь остальной трафик без маркировки.

DSCP - €вл€етс€ самосто€тельным элементом в архитектуре сети, описывающий механизм классификации, а также ќбеспечивающий ускорение и снижение задержек дл€ мультимедийного трафика. »спользуетс€ пространство пол€ ToS, €вл€ющийс€ компонентом вспомогательным QoS.

“еперь требуетс€ dscp ef и af отнести к необходимым внутренним классам expedited-forwarding и assured-forwarding. «а счет конфигурации classifiers, по€вл€етс€ возможность создани€ новых классов.

ex2200> show configuration class-of-service classifiers
dscp custom-dscp {
forwarding-class network-control {
loss-priority low code-points [ cs6 cs7 ];
}
forwarding-class expedited-forwarding {
loss-priority low code-points ef;
}
forwarding-class assured-forwarding {
loss-priority low code-points [ cs3 cs4 af41 ];
}
}
ex2200> show configuration class-of-service schedulers
sc-ef {
buffer-size percent 10;
priority strict-high;
}
sc-af {
shaping-rate 20m;
buffer-size percent 10;
}
sc-nc {
buffer-size percent 5;
priority strict-high;
}
sc-be {
shaping-rate percent 80;
buffer-size {
remainder;
}
}

Ќаименовани€ можно выбрать произвольно, но а процент выделенных буферов - в соответствии с необходимостью.  лючевым приоритетом работы QoS €вл€етс€ определение трафика с ограничением пропускающей полосы в зависимости от потребности в ней.

Ўедулеры сопоставл€ютс€ в соответствии с внутренними классами, в результате которого scheduler-map и classifier необходимо примен€етс€ ко всем интерфейсам, использу€ и описыва€ их в качестве шаблона.

  интерфейсу возможно примен€ть специфические настройки, подразумевающие возможность написани€ всевозможных scheduler и scheduler-maps дл€ различных интерфейсов.

 онечна€ конфигураци€ имеет следующий вид:

ex2200> show configuration class-of-service
classifiers {
dscp custom-dscp {
forwarding-class network-control {
loss-priority low code-points [ cs6 cs7 ];
}
forwarding-class expedited-forwarding {
loss-priority low code-points ef;
}
forwarding-class assured-forwarding {
loss-priority low code-points [ cs3 cs4 af41 ];
}
}
}
host-outbound-traffic {
forwarding-class network-control;
}
interfaces {
ge-* {
scheduler-map custom-maps;
unit 0 {
classifiers {
dscp custom-dscp;
}
}
}
ae* {
scheduler-map custom-maps;
unit 0 {
classifiers {
dscp custom-dscp;
}
}
}
}
scheduler-maps {
custom-maps {
forwarding-class network-control scheduler sc-nc;
forwarding-class expedited-forwarding scheduler sc-ef;
forwarding-class assured-forwarding scheduler sc-af;
forwarding-class best-effort scheduler sc-be;
}
}
schedulers {
sc-ef {
buffer-size percent 10;
priority strict-high;
}
sc-af {
shaping-rate 20m;
buffer-size percent 10;
}
sc-nc {
buffer-size percent 5;
priority strict-high;
}
sc-be {
shaping-rate percent 80;
buffer-size {
remainder;
}
}
}

ѕеред использованием данной настройки, проверьте командой commit check. ј при наличии следующей ошибки, следует учесть следующее:

[edit class-of-service interfaces]
'ge-*'
One or more "strict-high" priority queues have lower queue-numbers than priority "low" queues in custom-maps for ge-*. Ifd ge-* supports strict-high priority only on higher numbered queues.
error: configuration check-out failed

¬ итоге мы не можем указать приоритет "strict-high" только дл€ 5-ой очереди, когда у 7-ой останетс€ приоритет "low". ѕри этом можно решить проблему следующим образом: настроить дл€ network-control приоритет "strict-high".

ѕрименив конфигурацию, определенный процент фреймов в очеред€х будет потер€на. “ребуетс€ обнулить счетчики, проверить счетчики дропов через некоторое врем€, где переменные значени€ не равны нулю.

clear interfaces statistics all
show interfaces queue | match dropped | except " 0$"

ѕри росте счетчиков дропа в конфигурации есть ошибка. ≈сли вы пропустили описание в class-of-service interfaces шаблоном или в €вном виде, то трафик в классах со стопроцентной веро€тностью дропнетс€. ѕравильна€ работа выгл€дит следующим образом:

ex2200> show interfaces queue ge-0/0/22
Physical interface: ge-0/0/22, Enabled, Physical link is Up
Interface index: 151, SNMP ifIndex: 531
Forwarding classes: 16 supported, 4 in use
Egress queues: 8 supported, 4 in use
Queue: 0, Forwarding classes: best-effort
Queued:
Transmitted:
Packets : 320486
Bytes : 145189648
Tail-dropped packets : 0
RL-dropped packets : 0
RL-dropped bytes : 0
Queue: 1, Forwarding classes: assured-forwarding
Queued:
Transmitted:
Packets : 317
Bytes : 169479
Tail-dropped packets : 0
RL-dropped packets : 0
RL-dropped bytes : 0
Queue: 5, Forwarding classes: expedited-forwarding
Queued:
Transmitted:
Packets : 624
Bytes : 138260
Tail-dropped packets : 0
RL-dropped packets : 0
RL-dropped bytes : 0
Queue: 7, Forwarding classes: network-control
Queued:
Transmitted:
Packets : 674
Bytes : 243314
Tail-dropped packets : 0
RL-dropped packets : 0
RL-dropped bytes : 0

ѕереход к заводским настройкам

≈сли вам избавитс€ от вашей конфигурации, котора€ работает некорректно вы можете сбросить настройки до заводских параметров. —оветуем использовать данную функции, предусмотренную производителем оборудовани€, в случае реальной сложности в поиске ошибки, выполнив конфигурацию заново, вы можете заметно сэкономить свое врем€. —амый простой способ, это ввод следующей команды:

load factory defaults

ѕосле ввода команды, система оповестит ¬ас о том, что в данный момент будет осуществлена активаци€ заводских настроек по умолчанию. ј с помощью привычной команды "commit" активируем настройки и перезагружаемс€. ћы рассмотрели базовые настройки коммутаторов Juniper, позвол€ющих создание надежной и гибкой сети дл€ различных нужд.


ѕолезна ли ¬ам эта стать€?


Ёти статьи могут быть вам интересны: