Telegram- 👇 😉
-
. WIKIMERIONET
Merion Mertics , ,

CRM

OSPF:

OSPF

5

! OSPF. . .

OSPF:

:


(Stubby Area)

1 - OSPF

1 1 . . 1 . :

ATL2# configuration terminal
Enter configuration commands, one per line. End with CNTL/Z.
ATL2 (config)#router ospf 1
ATL2 (config-router)#area 1 stub
ATL2 (config-router)#end
ATL2#
ORL#  configuration terminal
Enter configuration commands, one per line. End with CNTL/Z .
ORL(config)#router ospf 1
ORL(config-router)#area 1 stub
ORL(config-router)#end
ORL#

. OSPF.

show ip route ospf
show ip route ospf

, ! ASBR. , ABR. , 1 ( ).

OSPF. , :

show ip ospf database
show ip ospf database

Type 4 LSA Type 5 LSA , Type 3 LSA .


(Totally Stubby Area)

, 1 . Type 3 LSA, Loopback 0 ATL ATL AT2. , , , -! :

ATL2#  configuration terminal
Enter configuration commands , one per line . End with CNTL/Z.
ATL2 (config)#router ospf 1
ATL2 (config-router )#area 1 stub no-summary
ATL2 (config-router )#end
ATL2#
show ip route ospf
show ip route ospf
show ip ospf database
show ip ospf database

Not So Stubby Area (NSSA)

, Not So Stubby Area (NSSA). , -, LSA 7. ABR LSA 5 OSPF ().

:

ATL2#  configuration terminal
Enter configuration commands , one per line. End with CNTL/Z.
ATL2 (config)#router ospf 1
ATL2 (config-router)#no area 1 stub
ATL2 (config-router)#area 1 nssa
ATL2 (config-router)#end
ATL2#

ORL# configuration terminal
Enter configuration commands , one per line . End with CNTL/Z.
ORL(config)#router ospf 1
ORL(config-router)#no area 1 stub
ORL(config-router)#area 1 nssa
ORL(config)#interface loopback10
ORL(config-if)#ip address 172.16.10. 255.255.255.0
ORL(config)#interface loopback20
ORL(config-if)#ip address 172.16.20. 255.255.255.0
ORL(config-if)#exit
ORL(config)#router eigrp 200
ORL(config-router)#network 172.16.10. 0.0.0.0
ORL(config-router)#network 172.16.20. 0.0.0.0
ORL(config-router)#exit
ORL(config)#router ospf 1
ORL(config-router)#redistribute eigrp 200 subnets metric 1000
ORL(config-router)#end
ORL#

. OSPF OSPF ORL:

show ip route ospf
show ip route ospf
show ip ospf database
show ip ospf database

, Type 3 0 (1.1.1.1 10.12.12.0). OSPF , NSSA , . , 1 Type 7 . ATL, , Type 5 LSA, .

show ip route ospf
show ip route ospf
show ip ospf database
show ip ospf database

, , NSSA. Type 5s, .

: NSSA . , ! , ATL2:

area 1 nssa default-information-originate

Totally NSSA

Totally Stubby, , Totally NSSA. LSA . Type 3 LSA. .

:

ATL2#  configuration terminal
Enter configuration commands , one per line . End with CNTL/Z.
ATL2 (config)#router ospf 1
ATL2 (config-router )#area 1 nssa no-summary
ATL2 (config-router )#end
ATL2#
show ip route ospf
show ip route ospf
show ip ospf database
show ip ospf database

, ( OSPF) ORL.

, OSPF LSA. OSPF.