ѕодпишитесь на наш Telegram-канал Ѕудьте в курсе последних новостей 👇 😉 ѕодписатьс€
ѕоддержим в трудное врем€ —пециальное предложение на техническую поддержку вашей »“ - инфраструктуры силами наших экспертов ѕодобрать тариф
ѕоставка оборудовани€ √аранти€ и помощь с настройкой. —кидка дл€ наших читателей по промокоду WIKIMERIONET  упить
»нтерфейс статистики Merion Mertics показывает ключевые диаграммы и графики по звонкам, а также историю звонков в формате, который легко поймет менеджер ѕопробовать бесплатно
¬недрение
офисной телефонии
Ўаг на пути к созданию доступных унифицированных коммуникаций в вашей компании ¬недрить
»нтеграци€ с CRM ѕомогаем навести пор€док с данными
и хранить их в единой экосистеме
ѕодключить
»“ Ѕезопасность ”мна€ информационна€ безопасность дл€ вашего бизнеса «аказать
ћерион Ќетворкс

14 минут чтени€

—оздание VLAN-ов, как и все другие конфигурации на сетевом оборудование, достигаетс€ путем ввода соответствующих команд. ¬ этой статье рассматриваютс€ настройка разных типов VLAN на коммутаторах Cisco.

–уководство по настройке VLAN

ƒиапазоны VLAN на коммутаторах Catalyst

¬ зависимости от модели, коммутаторы Cisco поддерживает разное число VLAN. „исла поддерживаемых VLAN обычно вполне достаточно дл€ задач большинства компаний. Ќапример, коммутаторы Cisco Catalyst 2960 и 3650 поддерживают больше 4000 виртуальных сетей. Ќормальный диапазон VLAN начинаетс€ от 1 до 1005, а расширенный Ц от 1006 до 4094. Ќа выводе внизу можно увидеть VLAN по умолчание на коммутаторе Cisco Catalyst 2960 с Cisco IOS 15 версии.

Switch# show vlan brief

VLAN Name              Status   Ports
---- ----------------- -------  --------------------
1    default           active   Fa0/1, Fa0/2, Fa0/3, Fa0/4
                                Fa0/5, Fa0/6, Fa0/7, Fa0/8
                                Fa0/9, Fa0/10, Fa0/11, Fa0/12
                                Fa0/13, Fa0/14, Fa0/15, Fa0/16
                                Fa0/17, Fa0/18, Fa0/19, Fa0/20
                                Fa0/21, Fa0/22, Fa0/23, Fa0/24
                                Gi0/1, Gi0/2
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

Ќормальный диапазон VLAN

Ќиже перечислены основные характеристики нормального диапазона:

  • ќни используютс€ в малых, средних и больших сет€х;
  • Ќумераци€ начинаетс€ от 1 до 1005;
  • »дентификаторы с 1002 до 1005 зарезервированы дл€ устаревших сетей (Token Ring, FDDI);
  • »дентификаторы с 1002 до 1005 созданы автоматически и не могут быть удалены;
  • —озданные VLAN хран€тс€ в пам€ти коммутатора в файле базы данных VLAN, именуемого vlan.dat;
  • VTP, если настроен, помогает распростран€ть все VLAN между коммутаторами.

–асширенный диапазон

Ќиже перечислены основные характеристики расширенного VLAN:

  • »спользуетс€ провайдерами и очень большими компани€ми;
  • Ќумераци€ начинаетс€ с 1006 по 4094;
  • ѕо умолчанию, они хран€тс€ в running-config;
  • »меют меньшую функциональность, чем нормальные VLAN;
  • ƒл€ настройки расширенного VLAN VTP должен работать в режиме transparent.
ѕримечание: ќграничение количества доступных VLAN продиктовано особенност€ми заголовка 802.1Q. ѕолю VLAN ID заголовка 802.1Q IEEE выделено всего 12 бит, поэтому 4096 -- верхн€€ граница доступных VLAN на коммутаторах Catalyst. ј если нужно больше, то можно обратитьс€ к такой технологии как VXLAN.

 оманды дл€ создани€ VLAN

 огда создаетс€ VLAN нормального диапазона, как уже было отмечено, эти настройки хран€тс€ в файле vlan.dat, то есть не нужно вводить команды copy running-config startup-config или write memory. “ем не менее, чтобы не потер€ть изменени€ сделанные нар€ду с созданием VLAN, рекомендуетс€ сохран€ть текущую конфигурацию.

¬ таблице ниже перечислены команды, которые нужно вводит дл€ создани€ VLAN и присвоени€ им названи€. ’орошей практикой считаетс€ давать VLAN пон€тные названи€, чтобы облегчить поиск и устранение проблем в будущем.

«адача

IOS команда

¬ойти в режим глобальной конфигурации

Switch# configure terminal

—оздать VLAN с валидным ID

Switch(config)# vlan vlan-id

”казать уникальное им€ дл€ идентификации VLAN

Switch(config-vlan)# name vlan-name

¬ернутьс€ в привилегированный режим EXEC

Switch(config-vlan)# end


ѕример создани€ VLAN

¬ топологии ниже, порт к которому подключен ѕ  Stundent, еще не добавлен ни в один VLAN, но у него есть IP 172.17.20.22, который принадлежит VLAN 20.

“опологи€ 1

ѕример ниже демонстрирует настройку VLAN 20 с названием student на коммутаторе S1.

S1# configure terminal
S1(config)# vlan 20
S1(config-vlan)# name student
S1(config-vlan)# end
ѕримечание:  роме создание VLAN-ов по одному, так же есть возможность создани€ нескольких влан, ввод€ их идентификаторы через зап€тые или дефис. Ќапример, команда vlan 100,102,105-107 в режиме конфигурации создаст сразу 5 VLAN-ов с идентификаторами 100, 102, 105, 106, и 107

ƒобавление портов в VLAN

ѕосле создани€ VLAN, следующий шаг Ц это добавление нужных портов в конкретный VLAN.

¬ таблице ниже приведены команды дл€ переведени€ порта в режим access и добавлени€ в конкретный VLAN.  оманда switchport mode access опциональна, но в цел€х безопасности рекомендуетс€ вводить ее, так как она принудительно переводит порт в режим access, что помогает защищатьс€ от атак вроде VLAN Hopping.

«адача

IOS команда

¬ойти в режим глобальной конфигурации

Switch# configure terminal

¬ойти в режим конфигурации интерфейса

Switch(config)# interface interface-id

”становить порт в режим access

Switch(config-if)# switchport mode access

ѕрисвоить порт VLAN'у.

Switch(config-if)# switchport access vlan vlan-id

¬ернутьс€ в привилегированный режим EXEC

Switch(config-if)# end

ѕримечание: ƒл€ одновременной конфигурации нескольких портов можно воспользоватьс€ командой interface range.

ѕример присвоени€ порту VLAN

¬ топологии ниже порт F0/6 коммутатора S1 настроен в режиме access и добавлен в VLAN 20. “еперь любое устройство, подключенное к данному порту, будет в 20-ом VLAN-е, как и ѕ 2 в нашем случае.

“опологи€ 2

ј ниже приведен пример команд дл€ реализации вышеуказанной цели.

S1# configure terminal
S1(config)# interface fa0/6
S1(config-if)# switchport mode access
S1(config-if)# switchport access vlan 20
S1(config-if)# end

VLAN настраиваетс€ на порту коммутатора, а не на конечном устройстве. ѕ 2 присвоен IP адреси маска подсети, котора€ относитьс€ к VLAN 20, а последний указан на порту коммутатора. ≈сли VLAN 20 настроить на другом коммутаторе, администратор сети должен настроить другой компьютер так, чтобы он был в одной подсети с ѕ 2 (172.17.20.0/24).


VLAN данных и голосовой VLAN

Ќа порту коммутатора в режиме access можно настроить не более одного VLAN-а данных. “ем не менее, на том же порту можно настроить голосовой VLAN. Ќапример, порт к которому подключены IP телефон и конечное устройство, может быть сразу в двух VLAN-ах, - голосовом и VLAN-е данных.

Ќапример, в топологии ниже, ѕ 5 подключен к IP телефону, который в свою очередь подключен к порту F0/18 коммутатора S3. ƒл€ реализации данной идеи созданы VLAN данных и голосовой VLAN.

“опологи€ 3

ѕример голосового VLAN и VLAN данных

„тобы настроить на интерфейсе голосовой VLAN используетс€ команда switchport voice vlan [vlan-id] в режиме конфигурации порта на коммутаторе.

¬ сет€х, где поддерживаетс€ голосовой трафик, обычно настраиваютс€ различные QoS. √олосовой трафик должен быть маркирован доверенным, как только попадет на интерфейс. „тобы пометить голосовой трафик как доверенный, а так же указать какое поле пакета используетс€ дл€ классификации трафика, примен€етс€ команда mls qos trust [cos | device cisco-phone | dscp | ip-precedence] в режиме конфигурации интерфейса.

 онфигураци€ в примере ниже создаст два VLAN-а и присвоит порту F0/18 коммутатора S3 VLAN данных с идентификатором 20, а также голосовой VLAN 150 и включит QoS, на основе CoS.

S3(config)# vlan 20
S3(config-vlan)# name student
S3(config-vlan)# vlan 150
S3(config-vlan)# name VOICE
S3(config-vlan)# exit
S3(config)# interface fa0/18
S3(config-if)# switchport mode access
S3(config-if)# switchport access vlan 20
S3(config-if)# mls qos trust cos
S3(config-if)# switchport voice vlan 150
S3(config-if)# end

≈сли на коммутаторе еще не создан нужный VLAN команда switchport access vlan принудительно создаст его. Ќапример, VLAN 30 не выводитс€ при вводе команды switchport vlan brief. Ќо если ввести команду switchport access vlan 30 без предварительного создани€ под любым интерфейсом на терминале выведетс€ соответствующее сообщение:

% Access VLAN does not exist. Creating vlan 30

ѕроверка настроек VLAN

ѕосле настроек VLAN, правильность конфигурации можно проверить с помощью команды show с последующим ключевым словом.

 оманда show vlan выводит список существующих VLAN. ƒанной команде можно задать разные параметры. ѕолный синтаксис команды такой: show vlan [brief | id vlan-id | name vlan-name | summary].

¬ таблице описываютс€ параметры команды show vlan.

«адача

ќпци€ команды

ќтображение имени, статуса и портов VLAN по одной VLAN на строку

brief

ќтображение информации об определенном номере VLAN ID. ƒл€ vlan-id диапазон от 1 до 4094

id vlan-id

ќтображение информации об определенном имени VLAN. Vlan-name - это строка ASCII от 1 до 32 символов.

name vlan-name

ќтображение сводной информации о VLAN

summary

 оманда show vlan summary выводит количество настроенных VLAN на коммутаторе:

S1# show vlan summary
Number of existing VLANs              : 7
Number of existing VTP VLANs          : 7
Number of existing extended VLANS     : 0

≈сть и другие полезные команды вроде show interfaces interface-id switchport и show interfaces vlan vlan-id. Ќапример, команда show interfaces fa0/18 switchport может использоватьс€ дл€ проверки правильно ли присвоен интерфейс F0/18 к голосовому VLAN и VLAN данных.

S1# show interfaces fa0/18 switchport
Name: Fa0/18
Switchport: Enabled
Administrative Mode: static access
Operational Mode: static access
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: native
Negotiation of Trunking: Off
Access Mode VLAN: 20 (student) 
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: 150
Administrative private-vlan host-association: none
(Output omitted)

ѕереназначение VLAN на интерфейсе

≈сть несколько вариантов переназначени€ интерфейсу VLAN-а.

≈сли неправильно сконфигурировали VLAN на интерфейсе, просто введите команду switchport access vlan vlan-id подставив нужный VLAN. Ќапример, представим что порт F0/18 добавлен в VLAN по умолчанию VLAN 1. „тобы помен€ть на VLAN 20, достаточно ввести switchport access vlan 20.

„тобы вернуть обратно в VLAN по умолчанию в режиме конфигурации интерфейса введите команду no switchport access vlan.

Ќа выводе ниже можно убедитьс€, что 18-ый порт коммутатора находитс€ в VLAN по умолчанию.

S1(config)# interface fa0/18
S1(config-if)# no switchport access vlan
S1(config-if)# end
S1#
S1# show vlan brief
VLAN Name                 Status    Ports
---- ------------------ --------- -------------------------------
1    default            active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
                                  Fa0/5, Fa0/6, Fa0/7, Fa0/8
                                  Fa0/9, Fa0/10, Fa0/11, Fa0/12
                                  Fa0/13, Fa0/14, Fa0/15, Fa0/16
                                  Fa0/17, Fa0/18, Fa0/19, Fa0/20
                                  Fa0/21, Fa0/22, Fa0/23, Fa0/24
                                  Gi0/1, Gi0/2
20   student            active    
1002 fddi-default       act/unsup 
1003 token-ring-default act/unsup 
1004 fddinet-default    act/unsup 
1005 trnet-default      act/unsup
—ледует заметить, что 20-ый VLAN все еще активен, несмотр€ на то, что под ним нет никакого интерфейса.
„тобы убедитьс€, что на 18-ый порт в VLAN 1, можно воспользоватьс€ командой show interfaces f0/18 switchport:
S1# show interfaces fa0/18 switchport
Name: Fa0/18
Switchport: Enabled
Administrative Mode: static access
Operational Mode: static access
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: native
Negotiation of Trunking: Off
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)

”даление VLAN

ƒл€ удалени€ VLAN используетс€ команда no vlan vlan-id в глобальном режиме конфигурации.

¬нимание: ѕрежде чем удалить VLAN убедитесь, что все интерфейсам с данным VLAN назначен другой.

„тобы удалить весь файл vlan.dat введите команду delete flash:vlan.dat в привилегированном режиме EXEC. ѕосле перезагрузки все настроенные на коммутаторе VLAN удал€тс€.

ѕримечание: „тобы сбросить коммутаторы Catalyst до заводских настроек отсоедините все кабели кроме кабел€ питани€ и консольного кабел€, от коммутатора. «атем введите erase startup-config после него delete vlan.dat. ѕосле перезагрузки коммутатор сброситс€ до первоначальных настроек.

Ќастройка Trunk

ѕосле создани€ и настройки VLAN, пора перейти к конфигурации Trunk портов. Trunk это св€зь на втором уровне OSI между коммутаторами, который пропускает все VLAN (если список разрешенных VLAN €вно не указан).

ƒл€ настройки интерфейса в режиме Trunk нужно воспользоватьс€ команды, указанные ниже в таблице:

«адача

IOS команда

¬ойти в режим глобальной конфигурации

Switch# configure terminal

¬ойти в режим конфигурации интерфейса

Switch(config)# interface interface-id

”становите порт в режим посто€нного транкинга

Switch(config-if)# switchport mode trunk

”станавливает дл€ native VLAN значение, отличное от VLAN 1

Switch(config-if)# switchport trunk native vlan vlan-id

”кажите список VLAN, разрешенных дл€ транка

Switch(config-if)# switchport trunk allowed vlan vlan-list

¬ернутьс€ в привилегированный режим EXEC

Switch(config-if)# end


ѕример настройки Trunk

¬ топологии ниже VLAN 10, 20 и 30 обслуживают компьютеры Faculty, Student и Guest. ѕорт F0/1 коммутатора S1 настроек в режиме Trunk и пропускает VLAN-ы 10, 20, 30. VLAN 99 настроен в качестве native (VLAN по умолчанию).

“опологи€ 4

¬ данном примере показываетс€ настройка порта в режиме trunk, смена VLAN по умолчанию и ограничение разрешенных VLAN.

S1(config)# interface fastEthernet 0/1
S1(config-if)# switchport mode trunk
S1(config-if)# switchport trunk native vlan 99
S1(config-if)# switchport trunk allowed vlan 10,20,30,99
S1(config-if)# end
ѕримечание: ¬ данном примере подразумеваетс€, что используетс€ коммутатор Cisco Catalyst 2960, в котором порты по умолчанию используют 802.1Q. Ќа других коммутаторах может понадобитьс€ ручна€ настройка режима энкапсул€ции на интерфейсе. “ак же следует настроить VLAN по умолчанию на обоих концах, иначе коммутатор будет выдавать ошибки.

ѕроверка настройки Trunk

¬ывод ниже демонстрирует настройки интерфейса Fa0/1 коммутатора S1. ƒанный вывод получен с помощью команды show interfaces interface-ID switchport:

S1# show interfaces fa0/1 switchport
Name: Fa0/1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 99 (VLAN0099)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none 
Administrative private-vlan mapping: none 
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
(output omitted)

ѕодчеркнутые части показывают режим работы интерфейса и нативный VLAN.


—брос trunk до настроек по умолчанию

ƒл€ сброса настроек транкового интерфейса используйте команды no switchport trunk allowed vlan и no switchport trunk native vlan. ѕосле сброса настроек данный порт будет пропускать все VLAN-ы и VLAN-ом по умолчанию будет VLAN 1.

S1(config)# interface fa0/1
S1(config-if)# no switchport trunk allowed vlan
S1(config-if)# no switchport trunk native vlan
S1(config-if)# end

¬ывод команды show interfaces f0/1 switchport показывает, что порт сброшен до настроек по умолчанию:

S1# show interfaces fa0/1 switchport
Name: Fa0/1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default) 
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none 
Administrative private-vlan mapping: none 
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
(output omitted)

¬ вывод ниже показывает команды, которые используютс€ дл€ смены режима работы интерфейс с trunk на access.

S1(config)# interface fa0/1
S1(config-if)# switchport mode access
S1(config-if)# end
S1# show interfaces fa0/1 switchport
Name: Fa0/1
Switchport: Enabled
Administrative Mode: static access
Operational Mode: static access
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: native
Negotiation of Trunking: Off
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
(output omitted)