Telegram- 👇 😉
-
. WIKIMERIONET
Merion Mertics , ,

CRM

3

  QinQ

802.1ad (QinQ) 802.1q. , , 2 OSI ( L3 )

? , .

  QinQ

4 (32 ) :

  • TPID (Tag Protocol Identifier): 0x8100 802.1q (VLAN) , 802.1ad(QinQ) : 0x88a8.
  QinQ
  • TCI (Tag Control Information): 16 .

:

  • PCP(Priority) - 3- , IEEE 802.1p . (3 )
  • Drop eligible indicator (DEI) ( CFI - Canonical Format Indicator) - PCP , . (1 )
  • VID (VLAN Identifier) - VLAN ID . 12 , 2^12 = 4096 VLAN . , 0 4095( 0x000 0xFFF) , 4094 . (12 )

QinQ? VID VLAN (4094) 802.1ad, VLAN. (4094*4094 = 16760836 - .)

dump 802.1q:

 802.1q

802.1ad QinQ :

802.1ad  QinQ

, . ( ), QinQ .

 QinQ

.

    QinQ

VPC1 VPC2 , .

  • VPC1 : 172.16.20.1/24
  • VPC2 : 172.16.20.2/24

Mikrotik, access trunk

/interface bridge
add name=bridge vlan-filtering=yes

/interface bridge port
add bridge=bridge interface=ether1 pvid=100
add bridge=bridge interface=ether2

/interface bridge vlan
add bridge=bridge tagged=ether2 vlan-ids=100

Mikrotik4

/interface bridge
add name=bridge vlan-filtering=yes

/interface bridge port
add bridge=bridge interface=ether1 pvid=100
add bridge=bridge interface=ether2

/interface bridge vlan
add bridge=bridge tagged=ether2 vlan-ids=100

: Mikrotik2

/interface bridge
add ether-type=0x88a8 name=bridge vlan-filtering=yes

/interface bridge port
add bridge=bridge interface=ether1 pvid=200 tag-stacking=yes
add bridge=bridge interface=ether2

/interface bridge vlan
add bridge=bridge tagged=ether1 vlan-ids=100
add bridge=bridge tagged=ether2 vlan-ids=200

Mikrotik3

/interface bridge
add ether-type=0x88a8 name=bridge vlan-filtering=yes

/interface bridge port
add bridge=bridge interface=ether1
add bridge=bridge interface=ether2 pvid=200 tag-stacking=yes

/interface bridge vlan
add bridge=bridge tagged=ether2 vlan-ids=100
add bridge=bridge tagged=ether1 vlan-ids=200

Mikrotik. , Q-in-Q, . !