—просите про Asterisk в Telegram - чате

ћерион Ќетворкс

4 минуты чтени€

¬сем привет! ¬ сегодн€шней статье расскажем о том, как настроить отправку статистики о пакетах, проход€щих через наш роутер Mikrotik на коллектор дл€ дальнейшего анализа. ¬се мы знаем про такой протокол как Netflow, предназначенный дл€ учЄта сетевого трафика, разработанный компанией Cisco, так вот у Mikrotik есть сво€ реализаци€ данного решени€, котора€ полностью совместима со стандартом Cisco Netflow - Mikrotik Traffic Flow.

ѕомимо мониторинга и анализа трафика, с помощью Traffic Flow, администратор может вы€вл€ть различные проблемы, которые могут по€вл€тьс€ в сети, а также анализировать и оптимизировать общие сетевые характеристики.

ѕоскольку Traffic Flow полностью совместим с Cisco Netflow, то он может использоватьс€ различными утилитами, которые разработаны дл€ Netflow.

Traffic Flow поддерживает следующие версии Netflow:

  1. version 1 - —ама€ перва€ верси€ формата данных Netflow. –екомендуетс€ использовать только если нет альтернатив
  2. version 5 - ƒополнение первой версии, которой по€вилась возможность добавлени€ номеров автономных систем (AS) BGP и пор€дковых номеров потоков
  3. version 9 - нова€ верси€, позвол€юща€ добавл€ть новые пол€ и типы записей благодар€ шаблонному исполнению

Ќастройка

»так, дл€ того, чтобы начать собирать статистическую информацию о трафике, необходимо сначала включить Traffic Flow и определитьс€ с каких интерфейсов осуществл€ть сбор. ƒелаетс€ это при помощи комбинации следующих команд:

/ip traffic-flow set enabled=yes 
interfaces=ether1

¬ нашем случае, указан лишь один интерфейс ether1, однако, если вы хотите собирать статистику с нескольких интерфейсов, просто укажите их через зап€тую. ≈сли со всех - интерфейсов введите interfaces=all.

¬ы также можете настроить количество потоков, которые могут одновременно находитьс€ в пам€ти роутера командой cache-entries и указав нужное значение - (128k | 16k | 1k | 256k | 2k / 4k - по умолчанию)

 омандой active-flow-timeout - можно настроить максимальное врем€ жизни потока, по умолчанию это 30 минут.

Ќекоторые потоки, могут стать неактивными через какое-то врем€, то есть, в них не будет происходить обмен пакетами, этот тайм-аут настраиваетс€ командой inactive-flow-timeout. ≈сли пакетов в потоке нет и данное врем€ истекло, то в следующий раз traffic flow создаст новый поток, если обмен возобновитс€. ѕо умолчанию это 15 секунд, но если сделать данное врем€ слишком коротким, то это может привести к созданию большого количества отдельных поток и переполнению буфера.

ѕосле того как мы включили Traffic Flow и определились с интерфейсами, с которых хотим получать информацию о потоках, необходимо настроить хост назначени€, который будет получать данную информацию (в терминологии Netflow такой хост называетс€ коллектором). ƒелаетс€ это при помощи следующей команды

ip traffic-flow target

«атем указываетс€ IP адрес и UDP порт хоста назначени€ -add dst-address=(IP address) port=(UDP port). ≈сли вы хотите использовать конкретную версию протокола, то укажите ее командой version= (1,5,9)


ѕример

–ассмотрим пример конфигурации Traffic Flow на роутере Mikrotik

ƒопустим мы хотим собирать статическую информацию о трафике, который проходит через интерфейс ether3 нашего роутера и отправл€ть еЄ на коллектор по адресу 192.168.2.123 использу€ 5 версию протокола. ¬ этом случае конфигураци€ может выгл€деть следующим образом:

—начала включаем Traffic Flow и указываем интерфейс

/ip traffic-flow set enabled=yes 
interfaces=ether3

«атем указываем адрес коллектора, стандартный порт и версию протокола 5:

/ip traffic-flow target add dst-address=192.168.2.123 
port=2055 
version=5

≈сли ¬ы предпочитаете консоли утилиту WinBox, то дл€ настройки Traffic Flow левом меню откройте пункт IP и выберите Traffic Flow, перед ¬ами откроетс€ следующее окно:

¬се про трафик с Netflow на MikroTik

Ќеобходимо включить Traffic Flow, поставив галочку напротив Enabled и выбрать желаемый интерфейс дл€ сбора информации.

ѕосле этого переходим на вкладку Targets и добавл€ем параметры коллектора, достаточно внести IP адрес, порт и версию. ѕосле этого нажимаем на кнопку Apply

Targets в Netflow на MikroTik

ѕосле этого наш роутер начнет отправл€ть информацию на коллектор. ≈сли вы хотите указать несколько коллекторов, то это можно сделать, использу€ разные версии протокола и номера UDP портов.


ѕолезна ли ¬ам эта стать€?


Ёти статьи могут быть вам интересны: