ѕодпишитесь на наш Telegram-канал Ѕудьте в курсе последних новостей 👇 😉 ѕодписатьс€
ѕоддержим в трудное врем€ —пециальное предложение на техническую поддержку вашей »“ - инфраструктуры силами наших экспертов ѕодобрать тариф
ѕоставка оборудовани€ √аранти€ и помощь с настройкой. —кидка дл€ наших читателей по промокоду WIKIMERIONET  упить
»нтерфейс статистики Merion Mertics показывает ключевые диаграммы и графики по звонкам, а также историю звонков в формате, который легко поймет менеджер ѕопробовать бесплатно
¬недрение
офисной телефонии
Ўаг на пути к созданию доступных унифицированных коммуникаций в вашей компании ¬недрить
»нтеграци€ с CRM ѕомогаем навести пор€док с данными
и хранить их в единой экосистеме
ѕодключить
»“ Ѕезопастность ”мна€ информационна€ безопасность дл€ вашего бизнеса «аказать
ћаксим Ћопунов

7 минут чтени€

FHRP (ѕротокол резервировани€ первого перехода) - это группа протоколов способные обеспечить клиентов отказоустойчивым шлюзом.

„то за первый переход такой?. ” нас есть коммутируема€ среда (SW1) и есть Internet . Internet это маршрутизируема€ среда . » дл€ того чтобы перейти из коммутируемой среды , в маршрутизируемую среду дл€ того чтобы выйти в интернет , как раз эти роутеры(R1,R2,VR - Virtual Router) обеспечивают данный переход и дл€ того ,чтобы обеспечить отказоустойчивость этого перехода , его нужно резервировать . ј потому и называетс€ протоколы резервировани€ первого перехода.

» все протоколы группы FHRP будут работать в единой логике: R1 , R2 будут прикидыватьс€ VR и в случае отказа одного из маршрутизаторов, то его работу возьмет другой.

ѕротоколы группы FHRP (First Hop Redundancy Protocols)
  • Forwarding Router ( FR ) - это роутер ,который данный момент активен и маршрутизирует трафик .
  • Standby Router ( SR ) - это роутер ,который стоит в резерве и ждет , когда накроетс€ FR ,чтобы перехватите его работу на себ€ , в случае сбо€ маршрутизатора.
  • FHRPs - это группа ,а значит пришло врем€ познакомить вас с этими протоколами.
    • HSRP (Hot Standby Router Protocol) - ѕроприетарный протокол разработанный Cisco;
    • VRRP (Virtual Router Redundancy Protocol) - —вободный протокол ,сделан на основе HSRP;
    • GLBP (Gateway Load Balancing Protocol) - ѕроприетарный протоколCisco , обеспечивающий распределение нагрузки на несколько маршрутизаторов( шлюзов) использу€ 1 виртуальный адрес.
    • CARP( Common Address Redundancy Protocol) - свободный , разработан как часть OpenBSD , портирован во FreeBSD.

»так начнЄм с HSRP

 оротко табличка с адресацией:

табличка с адресацией

ѕротокол HSRP рассчитан на 2 роутера, 3 это уже лишний и с этим уже справитьс€ протокол GLBP

ѕредположим ,что R3 это маршрутизатор выхода в интернет и дл€ этого мы поднимем на нЄм Loopback 1 с адресом 200.200.200.200 и пропишем его в маршруте по умолчанию. ћежду маршрутизаторами будет настроен RIPv2 и будут анонсированы 2 классовые сети( network 10.0.0.0 и network 192.168.0.0) дл€ простоты анонсировани€ маршрутов.

R2,R0 настраиваетс€ также. ј теперь по пор€дку , настроим HSRP:

  • Router(config)# interface fa 0/1 - переходим на интерфейс fast ethernet 0/1 (этот интерфейс смотрит в локальную сеть на коммутатор )
  • Router(config-if)# ip address 192.168.0.2 255.255.255.0 - задаем ip адрес дл€ физического интерфейса
  • Router(config-if)# standby 1 ip 192.168.0.254 - задаем виртуальный ip адрес (который будет основным шлюзом дл€ свитчей, смотр€щих на конфигурируемый роутер). ” обоих роутеров он одинаковый
  • Router(config-if)# stanby 1 priority 110 - устанавливаем приоритет данного роутера в 110 (по умолчанию приоритет 100)
  • Router(config-if)# standby 1 preempt - задаем режим приемтинга
  • Router(config-if)# standby 1 authentication md5 key-string MyPassword - задаем аутентификацию, если необходимо. ѕароль будет передаватьс€ с защитой алгоритмом хешировани€ md5, пароль будет MyPassword
  • R3(config-if)# standby 1 timers 100 255 - регулировка таймеров hsrp, где 100 - hello интервал в секундах (как часто посылаютс€ пакеты hello пакеты keep-alive) и 255 - hold interval в секундах (через какой промежуток времени признавать соседа недоступным)
  • Router(config-if)# standby 1 preempt delay minimum 300 - настройка времени задержки (в секундах), через которое роутер будет становитьс€ главным. Ёта команда требуетс€ дл€ того,чтобы сначала отработали другие протоколы,прежде чем заработает HSRP . ѕример: OSPF включенный на роутере в большой сети не успеет передать маршруты все ,а тут сразу заработает HSRP ,естественно он знать все маршруты не будет,а значить и стабильно гнать трафик тоже.  ак раз врем€ delay он будет использовать дл€ того,чтобы дать OSPF передать все маршруты и после этого вкл HSRP.

TRACKING

“акже полезно вешать TRACK на интерфейсы ,так как HSRP работает только в сторону ,куда направлен интерфейс ,то он не сможет отработать,когда упадут линки ,смотр€щие на роутеры выше.(в данном случае это R3)

  • Router(config)# track 1 interface fa0/1 line-protocol - отслеживаем состо€ние интерфейса fa0/1, если он падает, то сработает объект отслеживани€ track 1.
  • Router(config-if)# standby 1 track 1 decrement 15 - если сработает объект отслеживани€ track 1, то текущий приоритет будет понижен на 15 единиц.
  • Router(config-if)# standby 1 track 1 fa0/1 20 - работает только в HSRP. ѕозвол€ет отслеживать интерфейс без дополнительного создани€ объекта отслеживани€.

R1,R2,R0 будут настраиватьс€ одинаково, принцип сохран€етс€.


ј теперь нюансы HSRP

ѕри работе нескольких VLAN , HSRP может идти трафик не совсем рационально. ѕредставим ,что R1 это root primary за 10 VLAN, а R3 это ACTIVE router в HSRP . Ёто значит ,что любой трафик за этот VLAN будет идти следующим образом:VPC - R3 - R1 - R4 вместо того,чтобы идти напр€мую VPC - R3 - R4

нюансы HSRP

ѕоэтому рекомендуют использовать HSRP version 2(по умолчанию вкл 1 максимум 255 процессов,а во 2 их 4095) и использовать наилучший приоритет дл€ того роутера, который сейчас в сети root primary за текущий VLAN. » хорошей практикой будет если номер VLAN будет совпадать с номером процесса HSRP. ( є HSRP = VLAN )

нюансы HSRP

3 –оутера в HSRP не имеет смысла держать,так как он всЄ равно будет в состо€нии Listen и включитьс€ только тогда,если active пропадет, standby займет его место , и только тогда он перейдет в состо€нии standby.(речь идет о 3 роутере) “оже самое будет касатьс€ 4,5 ...n роутеров.


SLA

Ѕывает и друга€ ситуаци€ ,когда не сам линк от R1 падает ,а устройство наход€щиес€ за ним,к примеру SW2 упал link до R3. ѕроблему способен решить сервис SLA - Service Level Agreement.

—уть его проста,он ping сервис до провайдера и если он падает ,то отрабатывает track.

отрабатывает track
  • Router(config)# ip sla 1 - создаем зонд
  • Router(config-ip-sla)# icmp-echo 215.215.215.2 source-interface e0/2 - посылаем icmp echo ping на 215.215.215.2
  • Router(config-ip-sla-echo)# frequency 10 - посылаем icmp echo ping с частотой каждые 10 секунд
  • Router(config)# ip sla schedule 1 start-time now life forever - задаем расписание работы ip sla. ¬ данном случае зон будет запущен пр€мо сейчас, при этом врем€ окончани€ не задано (навсегда)
  • Router(config)# track 1 ip sla 1 reachability - устанавливаем объект отслеживани€ на доступность того хоста, на который посылаем icmp echo ping
  • Router(config)# ip route 0.0.0.0 0.0.0.0 2.2.2.2 track 1 - направл€ем трафик по этому маршруту если объект трекинга track 1 работает (хост пингуетс€)
  • Router(config)# ip route 0.0.0.0 0.0.0.0 3.3.3.3 10 - если не пингуетс€, направл€ем трафик в интернет по другому маршруту (¬нимание! «десь важно задать именно плохую метрику, например 10, иначе будут работать оба маршрута! (балансировка))
  • Router# show track 1 - показать состо€ние объекта отслеживани€

VRRP

Ќастройка VRRP не сильно отличаетс€ от HSRP . Ќастраиваетс€ он также как и HSRP, только вместо standby используетс€ vrrp. Router(config-if)# vrrp 1 ip 192.168.1.1 - включение vrrp. ѕроще пройтись по отличи€м ,чем заново описывать все команды.

  1. ” VRRP тоже только 2 состо€ни€ Master и Backup(HSRP active и standby)
  2. Preempt включен по умолчанию (HSRP он отключен)
  3. ѕри падении линка VRRP проводит выборы роутера(HSRP имеет запасной). √лавного выбирают по IP адресу, когда провод€т выборы.
  4. ѕоддержка јутентификации в VRRP отсутствует (RFC отсутствует),но в Cisco она реализована(HSRP по умолчанию)
  5. VRRP по умолчанию hello таймер равен 1 секунде , dead таймер равен 3(у HSRP 3 и 10 соответственно)
  6. ¬иртуальный адрес может совпадать с адресом интерфейса(HSRP такой адрес не даст прописать)
  7. »спользует Multicast HSRP равен 224.0.0.2 ( version 1) 224.0.0.102 (version 2) ,а VRRP 224.0.0.18
  8. ћожет отслеживать только объекты , а HSRP и интерфейсы , и объекты.(смотри раздел tracking)

ƒиагностика

  • Router# show standby (vrrp or glbp) - показать общую информацию по протоколу группы FHRP
  • Router# show standby brief - показать информацию по протоколу группы FHRP в виде таблицы