ѕодпишитесь на наш Telegram-канал Ѕудьте в курсе последних новостей 👇 😉 ѕодписатьс€
ѕоддержим в трудное врем€ —пециальное предложение на техническую поддержку вашей »“ - инфраструктуры силами наших экспертов ѕодобрать тариф
ѕоставка оборудовани€ √аранти€ и помощь с настройкой. —кидка дл€ наших читателей по промокоду WIKIMERIONET  упить
»нтерфейс статистики Merion Mertics показывает ключевые диаграммы и графики по звонкам, а также историю звонков в формате, который легко поймет менеджер ѕопробовать бесплатно
¬недрение
офисной телефонии
Ўаг на пути к созданию доступных унифицированных коммуникаций в вашей компании ¬недрить
»нтеграци€ с CRM ѕомогаем навести пор€док с данными
и хранить их в единой экосистеме
ѕодключить
»“ Ѕезопастность ”мна€ информационна€ безопасность дл€ вашего бизнеса «аказать
ћерион Ќетворкс

14 минут чтени€

“еперь мы можем продолжить поиск и устранение неисправностей. ¬ большинстве случаев вы ожидаете увидеть определенную сеть в таблице маршрутизации, но ее там нет. ƒалее рассмотрим несколько сценариев неправильной (или полностью не рабочей) работы EIGRP и как исправить наиболее распространенные ошибки. Ќиже перечислены часто встречающиес€ ошибки:

ѕервую часть статьи про траблшутинг EIGRP можно почитать здесь.
  •  то-то настроил distribute-list, чтобы информаци€ о маршрутах фильтровалась.
  • Ѕыло настроено автосуммирование или кто-то настроил суммирование вручную
  • Split-horizon блокирует объ€вление маршрутной информации.
  • ѕерераспределение было настроено, но информаци€ из EIGRP не используетс€.
  • ѕерераспределение было настроено, но никакие внешние маршруты EIGRP не отображаютс€.

Case #1

ѕроста€ топологи€

ƒавайте начнем с простой топологии. OFF1 и OFF2 работают под управлением EIGRP, и каждый маршрутизатор имеет интерфейс обратной св€зи. ¬от конфигураци€ обоих маршрутизаторов:

OFF1(config)#router eigrp 12
OFF1(config-router)#no auto-summary
OFF1(config-router)#network 1.1.1.0 0.0.0.255
OFF1(config-router)#network 192.168.12.0 0.0.0.255
OFF2(config)#router eigrp 12
OFF2(config-router)#no auto-summary
OFF2(config-router)#network 2.2.2.0 0.0.0.255
OFF2(config-router)#network 192.168.12.0 0.0.0.255

¬се работает нормально, пока через пару недель один из пользователей не пожаловалс€ на то, что ему не удалось подключитьс€ к сети 2.2.2.0 / 24 из-за OFF1. ѕосмотрите на таблицу маршрутизации на OFF1, и вот что вы видите:

“аблица маршрутизации на OFF1

ѕо какой-то причине нет сети 2.2.2.0 / 24 в таблице маршрутизации.

не настроен distribute lists

¬идно, что на OFF1 не настроен distribute lists.

OFF2 содержит сеть 1.1.1.0 / 24

OFF2 содержит сеть 1.1.1.0 / 24 в своей таблице маршрутизации. ƒавайте выполним быструю отладку, чтобы увидеть, что происходит.

выполним быструю отладку

ќтладка показывает нам, что происходит. ѕрежде чем вы увидите это сообщение, придетс€ немного подождать, или вы можете сбросить соседство EIGRP, чтобы ускорить процесс.  ак видите, в сети 2.2.2.0 / 24 отказано из-за distribute list.

отказано из-за distribute list

ƒругой быстрый способ проверить это - использовать команду show ip protocol.

show run

¬ этом случае использование show run могло бы быстрее обнаружить distribute-list.

список доступа, доставл€ющий нам непри€тности

¬от список доступа, доставл€ющий нам непри€тности.

OFF2(config)#router eigrp 12
OFF2(config-router)#no distribute-list 1 out

”далим distribute-list.

”далим distribute-list

«адача решена!

»звлеченный урок: если команды network верны, проверьте, есть ли у вас distribute-list, который запрещает объ€вл€ть префиксы или устанавливать их в таблицу маршрутизации.

»мейте в виду, distribute-list могут быть настроены как вход€щие или исход€щие, как список доступа.


Case #2

2 маршрутизатора, но разные сети в loopback

¬ следующем сценарии те же 2 маршрутизатора, но разные сети в loopback. ¬от конфигураци€:

OFF1(config)#router eigrp 12
OFF1(config-router)#network 192.168.12.0
OFF1(config-router)#network 10.0.0.0
OFF2(config)#router eigrp 12
OFF2(config-router)#network 192.168.12.0
OFF2(config-router)#network 10.0.0.0

 ак вы видите - это довольно базова€ конфигураци€.

таблицы маршрутизации таблицы маршрутизации

√л€д€ на таблицы маршрутизации, не видно сети 10.1.1.0 / 24 или 10.2.2.0 / 24. ¬идна запись дл€ сети 10.0.0.0/8, указывающую на интерфейс null0. Ёта запись отображаетс€ только при настройке суммировани€ и используетс€ дл€ предотвращени€ циклов маршрутизации.

ƒавайте включим отладку и посмотрим, что мы можем найти

ƒавайте включим отладку и посмотрим, что мы можем найти.

OFF2#clear ip eigrp 12 neighbors

Ётой командой мы сделаем сброс соседства EIGRP, чтобы ускорить процесс. »мейте в виду, что это, веро€тно, не самое лучшее, что можно сделать в производственной сети, пока вы не узнаете, что не так, но это действительно помогает ускорить процесс.

сеть 10.2.2.0 / 24 не следует объ€вл€ть

¬от наш ответ. ќтладка говорит нам, что сеть 10.2.2.0 / 24 не следует объ€вл€ть, а сеть 10.0.0.0 / 8 нужно объ€вл€ть (это вкратце). Ёто может произойти по двум причинам:

  • —уммирование было кем-то настроено
  • јвто-суммирование включено дл€ EIGRP.
авто-суммирование включено дл€ EIGRP авто-суммирование включено дл€ EIGRP

 ак вы видите, авто-суммирование включено дл€ EIGRP. ¬ зависимости от версии IOS авто-суммирование включено или отключено по умолчанию.

OFF1(config)#router eigrp 12
OFF1(config-router)#no auto-summary
OFF2(config)#router eigrp 12
OFF2(config-router)#no auto-summary

ќтключение автоматического суммировани€ должно помочь.

сети по€вились в таблице маршрутизации сети по€вились в таблице маршрутизации

Ќу что, наши сети по€вились в таблице маршрутизации.

»звлеченный урок: если включена автоматическое суммирование EIGRP, вы можете столкнутьс€ с нестабильными сет€ми.

Case #3

2 маршрутизатора, но разные сети

ќчередна€ проблема. ¬ приведенном выше примере у нас есть 2 маршрутизатора, но разные сети. OFF1 содержит сеть 172.16.1.0 / 24 на интерфейсе обратной св€зи, а OFF2 содержит сеть 172.16.2.0 / 24 и 172.16.22.0 / 24 на своих интерфейсах обратной св€зи. ѕосмотрим конфигурацию EIGRP обоих маршрутизаторов:

все сети объ€вл€ютс€ все сети объ€вл€ютс€

 ак вы видите, что все сети объ€вл€ютс€. ќбратите внимание, что в OFF1 включено автоматическое суммирование, а в OFF2 отключено автоматическое суммирование.

 то-то настроил суммирование на OFF2 и отправл€ет ее на OFF1

 то-то настроил суммирование на OFF2 и отправл€ет ее на OFF1. —уммирование создана дл€ сети 172.16.0.0 / 16.

видим запись дл€ сети 172.16.0.0 / 16, но она указывает на интерфейс null0

ќднако, если посмотреть на таблицу маршрутизации OFF1, она не по€витс€. ћы видим запись дл€ сети 172.16.0.0 / 16, но она указывает на интерфейс null0, а не на OFF2. „то здесь происходит?

debug eigrp

OFF2#clear ip eigrp 12 neighbors

ƒавайте сделаем отладку на OFF2, чтобы увидеть, объ€вл€етс€ ли суммирование. ¬ыполним команду clear ip eigrp neighbors, просто чтобы ускорить процесс.

clear ip eigrp neighbors

√л€д€ на отладку, видно, что OFF2 работает правильно. ќн объ€вл€ет сводный маршрут 172.16.0.0 / 16 так, как должен. Ёто означает, что проблема должна быть в OFF1.

ƒавайте проведем отладку OFF1.

ƒавайте проведем отладку OFF1.

OFF1 получает сводный маршрут от OFF2, но решает не использовать его

ћы можем видеть, что OFF1 получает сводный маршрут от OFF2, но решает не использовать его.

проверка таблицы топологии EIGRP

Ёто хороший момент дл€ проверки таблицы топологии EIGRP. ¬ы видите, что он имеет суммирование сети 172.16.0.0 / 16 от OFF2 в своей таблице топологии EIGRP, но OFF1 решает не использовать ее, потому что вход через интерфейс null0 €вл€етс€ лучшим путем.

OFF1(config)#router eigrp 12
OFF1(config-router)#no auto-summary

–ешение состоит в том, что нам нужно избавитьс€ от записи null0 в таблице маршрутизации. ≈динственный способ сделать это - отключить автоматическое суммирование.

ќтключение автоматического суммировани€ удал€ет запись null0

ќтключение автоматического суммировани€ удал€ет запись null0, и теперь суммирование OFF2 установлено проблема решена!

»звлеченный урок: автоматическое суммирование EIGRP создает запись через интерфейс null0, котора€ может помешать установке суммировани€, которые вы получаете от соседних маршрутизаторов.

Case #4

“опологи€

≈сть еще одна проблема с суммированием, которую сейчас и разберем. ћы используем топологию, которую вы видите выше, и ниже конфигураци€ EIGRP обоих маршрутизаторов.

конфигураци€ EIGRP обоих маршрутизаторов конфигураци€ EIGRP обоих маршрутизаторов

¬се сети объ€влены, и автоматическое суммирование отключено на обоих маршрутизаторах.

—уммирование было настроено на OFF2

—уммирование было настроено на OFF2 и должно быть объ€влено к OFF1.

ничего не видно на OFF1

  сожалению, ничего не видно на OFF1. ƒавайте проверим OFF2, чтобы посмотреть, что не так.

команды Debug и show

 огда дело доходит до устранени€ неполадок с сетью, вашими друзь€ми €вл€ютс€ не Google или яндекс, а команды Debug и show.

единственна€ сеть, которую OFF2 объ€вл€ет

—транно, это единственна€ сеть, которую OFF2 объ€вл€ет.

OFF2 знает только о сети 192.168.12.0 / 24

ќдно из золотых правил маршрутизации: вы не можете объ€вл€ть то, чего у вас нет. ќчевидно, OFF2 знает только о сети 192.168.12.0 / 24.

 то-то выполнил команду отключени€ на интерфейсах обратной св€зи

¬от это ошибка!  то-то выполнил команду отключени€ на интерфейсах обратной св€зи.

OFF2(config)#interface loopback 0
OFF2(config-if)#no shutdown
OFF2(config)#interface loopback 1
OFF2(config-if)#no shutdown

¬ключим интерфейсы.

суммирование объ€вл€етс€

“еперь мы видим, что суммирование объ€вл€етс€.

суммирование в таблице маршрутизации OFF1

“еперь мы видим суммирование в таблице маршрутизации OFF1- проблема решена!

»звлеченный урок: вы не можете объ€вл€ть то, чего у вас нет в таблице маршрутизации.

¬ј∆Ќќ. ѕоследн€€ проблема может быть показатьс€ простой, но есть важный момент, который вы не должны забывать: дл€ объ€влени€ итогового маршрута в таблице маршрутизации объ€вл€емого маршрутизатора должен быть указан хот€ бы один префикс, попадающий в итоговый диапазон!


Case #5

концентратор Frame Relay и соответствующа€ топологи€

ƒавайте посмотрим на другую топологию. Ќа рисунке выше у нас есть концентратор Frame Relay и соответствующа€ топологи€.  аждый из OFF1 и OFF2 имеет интерфейс обратной св€зи, который мы будем объ€вл€ть в EIGRP. ¬от соответствующа€ конфигураци€ всех маршрутизаторов:

CONC(config)#router eigrp 123
CONC(config-router)#no auto-summary
CONC(config-router)#network 192.168.123.0
OFF1(config-if)#router eigrp 123
OFF1(config-router)#no auto-summary
OFF1(config-router)#network 192.168.123.0
OFF1(config-router)#network 2.2.2.0 0.0.0.255
OFF2(config)#router eigrp 123
OFF2(config-router)#no auto-summary
OFF2(config-router)#network 192.168.123.0
OFF2(config-router)#network 3.3.3.0 0.0.0.255

¬идно, что все сети объ€влены.

концентратор-маршрутизатор видит сети из двух OFF-маршрутизаторов

Ќаш концентратор-маршрутизатор видит сети из двух OFF-маршрутизаторов.

наши маршрутизаторы не вид€т ничего наши маршрутизаторы не вид€т ничего

  сожалению, наши маршрутизаторы не вид€т ничего ...

маршрутизатор-концентратор не объ€вл€ет сети

ѕохоже, что маршрутизатор-концентратор не объ€вл€ет сети, которые он изучает с помощью OFF-маршрутизаторов. ƒавайте включим отладку, чтобы увидеть, что происходит.

CONC#clear ip eigrp 123 neighbors

—бросим соседство EIGRP, чтобы ускорить процесс.

–азделение горизонта не позвол€ет размещать объ€вление от одного маршрутизатора на другой

¬ отладке мы видим, что наш маршрутизатор-концентратор узнает о сети 2.2.2.0 / 24 и 3.3.3.0 / 24, но объ€вл€ет только сеть 192.168.123.0 / 24 дл€ OFF-маршрутизаторов. –азделение горизонта не позвол€ет размещать объ€вление от одного маршрутизатора на другой.

CONC(config)#interface serial 0/0
CONC(config-if)#no ip split-horizon eigrp 123

ƒавайте отключим разделение горизонта на последовательном интерфейсе маршрутизатора-концентратора.

маршрутизатор-концентратор объ€вл€ет все сети

“еперь мы видим, что маршрутизатор-концентратор объ€вл€ет все сети.

маршрутизаторы теперь могут узнавать о сет€х друг друга, поскольку split horizon отключено маршрутизаторы теперь могут узнавать о сет€х друг друга, поскольку split horizon отключено

OFF-маршрутизаторы теперь могут узнавать о сет€х друг друга, поскольку split horizon отключено. Ёто хорошо, но это еще не все.

»звлеченный урок: RIP и EIGRP €вл€ютс€ протоколами маршрутизации на рассто€нии и используют split horizon. Split horizon предотвращает объ€вление префикса вне интерфейса, на котором мы его узнали.
’от€ сети отображаютс€ в таблицах маршрутизации мы не можем пропинговать от одного OFF-маршрутизатора к другому ’от€ сети отображаютс€ в таблицах маршрутизации мы не можем пропинговать от одного OFF-маршрутизатора к другому

’от€ сети отображаютс€ в таблицах маршрутизации мы не можем пропинговать от одного OFF-маршрутизатора к другому. Ёто не проблема EIGRP, но она св€зана с Frame Relay. ћы должны это исправить.

 огда OFF1 отправл€ет IP-пакет на OFF2, IP-пакет выгл€дит следующим образом:

OFF1 отправл€ет IP-пакет на OFF2

ƒавайте пока подумаем, как роутер, и посмотрим, что здесь происходит. —начала нам нужно проверить, знает ли OFF1, куда отправить 3.3.3.3:

знает ли OFF1, куда отправить 3.3.3.3

—уществует запись дл€ 3.3.3.3, а IP-адрес следующего перехода - 192.168.123.1 (маршрутизатор-концентратор). ћожем ли мы достичь 192.168.123.1?

записи маршрутизации

Ќет проблем, кажетс€, OFF1 может пересылать пакеты, предназначенные дл€ сети 3.3.3.0/24. ƒавайте перейдем к маршрутизатору CONC.

маршрутизатор CONC

” маршрутизатора-концентратора нет проблем с отправкой трафика в сеть 3.3.3.0 / 24, поэтому на данный момент мы можем сделать вывод, что проблема должна быть в маршрутизаторе OFF2.

IP-пакет, который получает маршрутизатор OFF2

Ёто IP-пакет, который получает маршрутизатор OFF2, и когда он отвечает, он создает новый IP-пакет, который выгл€дит следующим образом:

достигать IP-адрес 192.168.123.2

—пособен ли OFF2 достигать IP-адрес 192.168.123.2 ƒавайте узнаем!

OFF2 не может достичь IP-адреса 192.168.123.2

“еперь мы знаем проблему ... OFF2 не может достичь IP-адреса 192.168.123.2

сеть 192.168.123.0 / 24 подключена напр€мую

≈сли мы посмотрим на таблицу маршрутизации OFF2, то увидим, что сеть 192.168.123.0 / 24 подключена напр€мую. — точки зрени€ третьего уровн€ у нас нет никаких проблем. ѕришло врем€ перейти вниз по модели OSI и проверить уровень 2 ... или, может быть, между уровнем 2 и 3.

нет сопоставлени€ дл€ IP-адреса 192.168.123.2

Frame Relay использует Inverse ARP дл€ прив€зки уровн€ 2 (DLCI) к уровню 3 (IP-адрес). ¬ы можете видеть, что нет сопоставлени€ дл€ IP-адреса 192.168.123.2.

OFF2(config)#int s0/0
OFF2(config-if)#frame-relay map ip 192.168.123.2 301

ƒавайте frame-relay map сами.

роутер OFF2 знает, как св€затьс€ с роутером OFF1

“еперь роутер OFF2 знает, как св€затьс€ с роутером OFF1

маршрутизатор OFF1 может пропинговать интерфейс обратной св€зи маршрутизатора OFF2

Ќаконец, маршрутизатор OFF1 может пропинговать интерфейс обратной св€зи маршрутизатора OFF2.  огда мы пытаемс€ пропинговать от маршрутизатора OFF2 к интерфейсу обратной св€зи маршрутизатора OFF1, у нас возникает та же проблема, поэтому мы также добавим туда оператор frame-relay map:

OFF1(config)#int s0/0
OFF1(config-if)#frame-relay map ip 192.168.123.3 201
у нас есть extra frame-relay map на маршрутизаторе OFF1

“еперь у нас есть extra frame-relay map на маршрутизаторе OFF1.

пинг проходит

» наш пинг проходит! »звлеченный урок: убедитесь, что IP-адрес следующего прыжка доступен, и при необходимости добавьте frame-relay map.


Case #6

OFF1 и OFF2 работают c EIGRP AS 12

¬от вам совершенно другой сценарий. Ќа рисунке выше OFF1 и OFF2 работают c EIGRP AS 12. ¬се маршрутизаторы работают на RIP. OFF3 имеет loopback интерфейс с сетью 3.3.3.0 / 24, который будет объ€влен в RIP. OFF2 собираетс€ перераспределить эту сеть в EIGRP AS 12. ¬от конфигурации EIGRP и RIP всех маршрутизаторов:

конфигурации EIGRP и RIP всех маршрутизаторов конфигурации EIGRP и RIP всех маршрутизаторов конфигурации EIGRP и RIP всех маршрутизаторов

ќбратите внимание, что OFF2 был настроен дл€ перераспределени€ между EIGRP AS 12 и RIP.  ак это вли€ет на наш выбор маршрутизации?

OFF1 отправл€ет трафик в сеть 3.3.3.0 / 24

OFF1 отправл€ет трафик в сеть 3.3.3.0 / 24, использу€ последовательную св€зь между OFF1 и OFF3. Ѕыло бы лучше, если бы мы использовали канал между OFF1 и OFF2, потому что использование каналов FastEthernet быстрее, чем последовательный канал.

таблицу топологии EIGRP

ћы можем посмотреть на таблицу топологии EIGRP и увидеть, что OFF1 узнал о сети 3.3.3.0 / 24 через EIGRP от OFF2. “ак почему же мы не используем эту информацию вместо RIP? ѕроблема в том, что внешние маршруты EIGRP имеют AD (административное рассто€ние) 170, а RIP имеет AD 120.

OFF1(config)#router rip
OFF1(config-router)#distance 175 192.168.13.3 0.0.0.0

ћы можем решить эту проблему, изменив AD. ¬ приведенном выше примере мы установим AD в 175 дл€ всех маршрутов RIP, которые мы узнаем по IP-адресу 192.168.13.3 (OFF3).

“еперь мы используем каналы FastEthernet дл€ доступа к сети 3.3.3.0 / 24 “еперь мы используем каналы FastEthernet дл€ доступа к сети 3.3.3.0 / 24

“ак как AD EIGRP external (170) ниже, чем AD маршрутов RIP (175), OFF1 установит информацию EIGRP external . “еперь мы используем каналы FastEthernet дл€ доступа к сети 3.3.3.0 / 24 ... проблема решена!

»звлеченный урок: измените административное рассто€ние, чтобы помен€ть схему движени€, но имейте в виду, в более сложных топологи€х это также может вызвать циклы маршрутизации.
3 маршрутизатора

—ледующа€ проблема. —уществует 3 маршрутизатора, и OFF2 - это маршрутизатор, выполн€ющий перераспределение между EIGRP AS 12 и RIP. ¬от конфигурации:

OFF1 работает с EIGRP

 ак вы можете видеть, OFF1 работает с EIGRP, OFF2 работает c RIP и EIGRP и выполн€ет перераспределение, OFF3 работает только c RIP.

мы ожидаем увидеть некоторые перераспределенные маршруты

ќднако, когда мы изучаем таблицу маршрутизации OFF1, мы ожидаем увидеть некоторые перераспределенные маршруты.   сожалению, здесь ничего нет. ¬ чем дело?

изучил сеть 3.3.3.0 / 24 через RIP

OFF2 - маршрутизатор, выполн€ющий перераспределение, и мы видим, что он изучил сеть 3.3.3.0 / 24 через RIP. —ледует перераспределить эту сеть в EIGRP.

сети 3.3.3.0 / 24 нет в таблице топологии EIGRP OFF2

—транно, сети 3.3.3.0 / 24 нет в таблице топологии EIGRP OFF2, хот€ мы настроили перераспределение, давайте проверим конфигурацию перераспределени€:

проверим конфигурацию перераспределени€

” нас есть команда redistribute rip, но нет никакой начальной метрики по умолчанию. ≈сли вы не зададите метрику, то начальна€ метрика по умолчанию будет бесконечной. ƒругими словами, она недостижима.

OFF2(config)#router eigrp 12
OFF2(config-router)#default-metric 1500 100 255 1 1500

ƒавайте настроим начальную метрику по умолчанию. ¬ы должны сами указать пропускную способность, задержку, нагрузку и надежность. ѕросто используем случайные значени€.

сеть 3.3.3.0 /24 в таблице топологии EIGRP OFF2

“еперь мы видим сеть 3.3.3.0 /24 в таблице топологии EIGRP OFF2.

когда вы перераспредел€ете что-то в EIGRP, вам необходимо настроить начальные метрики

» в результате он может быть объ€влен в OFF1 ... проблема решена!

»звлеченный урок: когда вы перераспредел€ете что-то в EIGRP, вам необходимо настроить начальные метрики.