ѕодпишитесь на наш Telegram-канал Ѕудьте в курсе последних новостей 👇 😉 ѕодписатьс€
ѕоддержим в трудное врем€ —пециальное предложение на техническую поддержку вашей »“ - инфраструктуры силами наших экспертов ѕодобрать тариф
ѕоставка оборудовани€ √аранти€ и помощь с настройкой. —кидка дл€ наших читателей по промокоду WIKIMERIONET  упить
»нтерфейс статистики Merion Mertics показывает ключевые диаграммы и графики по звонкам, а также историю звонков в формате, который легко поймет менеджер ѕопробовать бесплатно
¬недрение
офисной телефонии
Ўаг на пути к созданию доступных унифицированных коммуникаций в вашей компании ¬недрить
»нтеграци€ с CRM ѕомогаем навести пор€док с данными
и хранить их в единой экосистеме
ѕодключить
»“ Ѕезопасность ”мна€ информационна€ безопасность дл€ вашего бизнеса «аказать

“раблшутинг EIGRP

„асть 1. ѕоиск проблем

ћерион Ќетворкс

9 минут чтени€

¬ этой статье мы рассмотрим протокол маршрутизации Cisco EIGRP. EIGRP (Enhanced Interior Gateway Routing Protocol) - это протокол расширенной векторной маршрутизации, который должен устанавливать отношени€ соседства перед отправкой обновлений. »з-за этого первое, что нам нужно сделать, это проверить, правильно ли работает соседство. ≈сли это так, мы можем продолжить, проверив, объ€вл€ютс€ сети или нет. ¬ этой статье рассмотрим все, что может пойти не так с EIGRP, как это исправить и в каком пор€дке. ƒавайте начнем с проверки соседства!

—уществует р€д элементов, которые вызывают проблемы соседства EIGRP:

  • Ќеизвестна€ подсеть: соседи EIGRP с IP-адресами, которые не наход€тс€ в одной подсети.
  • Ќесоответствие значений K: по умолчанию пропускна€ способность и задержка включены дл€ расчета метрики. ћы можем включить нагрузку и надежность, но мы должны сделать это на всех маршрутизаторах EIGRP.
  • Ќесоответствие AS: номер автономной системы должен совпадать на обоих маршрутизаторах EIGRP, чтобы сформировать соседство.
  • ѕроблемы уровн€ 2: EIGRP работает на уровне 3 модели OSI. ≈сли уровни 1 и 2 не работают должным образом, у нас будут проблемы с формированием соседства.
  • ѕроблемы со списком доступа: возможно, кто-то создал список доступа, который отфильтровывает многоадресный трафик. EIGRP по умолчанию использует 224.0.0.10 дл€ св€зи с другими сосед€ми EIGRP.
  • NBMA: по умолчанию Non Broadcast Multi Access сети, такие как Frame Relay, не разрешают широковещательный или многоадресный трафик. Ёто может преп€тствовать тому, чтобы EIGRP формировал соседние отношени€ EIGRP.
“опологи€
OFF1(config)#int f0/0
OFF1(config-if)#ip address 192.168.12.1 255.255.255.0
OFF1(config-if)#router eigrp 12
OFF1(config-router)#network 192.168.12.0

OFF2(config)#int f0/0
OFF2(config-if)#ip address 192.168.21.2 255.255.255.0
OFF2(config)#router eigrp 12
OFF2(config-router)#network 192.168.21.0

ќшибку неверной подсети легко обнаружить. ¬ приведенном выше примере у нас есть 2 маршрутизатора, и вы можете видеть, что были настроены разные подсети на каждом интерфейсе.

ѕосле включени€ EIGRP всплывают следующие ошибки:

осле включени€ EIGRP всплывают следующие ошибки осле включени€ EIGRP всплывают следующие ошибки

ќба маршрутизатора жалуютс€, что наход€тс€ не в одной подсети.

OFF2(config-router)#int f0/0
OFF2(config-if)#ip address 192.168.12.2 255.25
OFF2(config)#router eigrp 12
OFF2(config-router)#no network 192.168.21.0
OFF2(config-router)#network 192.168.12.0

ћы изменили IP-адрес на OFF2 и убедились, что дл€ EIGRP правильно настроена команда network.

команда network команда network

¬уал€! “еперь у нас есть соседство EIGRP.

“еперь у нас есть соседство EIGRP “еперь у нас есть соседство EIGRP

ѕроверим это с помощью команды show ip eigrp neighbors.

»звлеченный урок: убедитесь, что оба маршрутизатора наход€тс€ в одной подсети.

Case #2

“опологи€ є2

Ќа этот раз IP-адреса верны, но мы используем разные значени€ K с обеих сторон. OFF1 включил пропускную способность, задержку, нагрузку и надежность. OFF2 использует только пропускную способность и задержку.

OFF2 использует только пропускную способность и задержку

Ёту ошибку легко обнаружить, поскольку сообщение в консоли гласит "Ќесоответствие K-значений" на обоих маршрутизаторах.

Ќесоответствие K-значений

ћы можем проверить нашу конфигурацию, посмотрев ее на обоих маршрутизаторах.  ак вы видите, что значени€ K были изменены на OFF1.

OFF2(config)#router eigrp 12
OFF2(config-router)#metric weights 0 1 1 1 1 0

ƒавайте убедимс€, что значени€ K одинаковы на обоих маршрутизаторах, так как мы изменили их на OFF2.

убедимс€, что значени€ K одинаковы на обоих маршрутизаторах

ѕосле изменени€ значений K у нас по€вилось соседство EIGRP-соседей.

соседство EIGRP-соседей соседство EIGRP-соседей

≈ще одна проблема решена!

»звлеченный урок: убедитесь, что значени€ K одинаковы на всех маршрутизаторах EIGRP в одной и той же автономной системе.

Case #3

ƒавайте продолжим со следующей ошибкой ...

ќшибка

¬от еще один пример типичной проблемы. Ќесоответствие номера AS.  огда мы настраиваем EIGRP, мы должны ввести номер AS. ¬ отличие от OSPF (который использует ID процесса) этот номер должен быть одинаковым на обоих маршрутизаторах.

Ќесоответствие номера AS

¬ отличие от других неверных настроек конфигурации EIGRP, эта проблема не выдает сообщение об ошибке. »спользуем команду show ip eigrp neighbors и видим, что соседей нет. ¬нимательно изучите выходные данные, чтобы обнаружить различи€, и вы увидите, что маршрутизаторы используют разные номера AS.

маршрутизаторы используют разные номера AS

≈сли посмотреть на работающую конфигурацию, и мы увидим то же самое.

маршрутизаторы используют разные номера AS

ƒавайте изменим номер AS на OFF2.

изменим номер AS на OFF2

ѕосле смены номера AS все заработало как положено.

ѕосле смены номера AS все заработало
»звлеченный урок: убедитесь, что номера AS одинаковые, если вы хотите соседства EIGRP.

Case #4

» последнее, но не менее важное: если вы проверили номер AS, значени€ K, IP-адреса и у вас все еще нет работающего соседства EIGRP, вам следует подумать о безопасности. ¬озможно, access-list блокирует EIGRP и/или многоадресный трафик.

ACL блокирует EIGRP

—ледующа€ ситуаци€: оп€ть два маршрутизатора EIGRP и отсутствие соседства. „то здесь происходит?

два маршрутизатора EIGRP и отсутствие соседства

ћы видим, что нет соседей ...

нет соседей нет соседей

≈сли вы посмотрите на вывод команды show ip protocols, то увидите, что сеть была объ€влена правильно. ≈сли вы посмотрите внимательно на OFF2, вы увидите, что у нас есть пассивный интерфейс.

”далим настройки пассивного интерфейса!

OFF2(config)#router eigrp 12
OFF2(config-router)#no passive-interface fastEthernet 0/0

≈ще одна неправильна€ настройка создала нам проблемы, но мы ее решили.

проблема решена проблема решена

«адача решена!

»звлеченный урок: не включайте пассивный интерфейс, если вы хотите установить соседство EIGRP.

Case #5

список доступа на OFF2, который блокирует весь вход€щий многоадресный трафик

¬ приведенном выше примере у нас есть те же 2 маршрутизатора, но на этот раз кто-то решил, что было бы неплохо настроить список доступа на OFF2, который блокирует весь вход€щий многоадресный трафик.

соседство EIGRP с OFF2

«десь можно запутатьс€. Ќа OFF1 мы видим, что он считает, что установил соседство EIGRP с OFF2. Ёто происходит потому, что мы все еще получаем пакеты EIGRP от OFF2.

debug eigrp neighbors

»спользуем команду debug eigrp neighbors, чтобы посмотреть, что происходит. ќчевидно, что OFF1 не получает ответ от своих hello messages, holdtime истекает, и это отбрасывает установление соседства EIGRP.

эхо-запрос по адресу многоадресной рассылки 224.0.0.10

Ѕыстрый способ проверить подключение - отправить эхо-запрос по адресу многоадресной рассылки 224.0.0.10, который использует EIGRP. ћџ видим, что мы ответа нет от этого запроса. –екомендуетс€ проверить, есть ли в сети списки доступа.

TSTETSTST

“ак, так! ћы нашли что-то ...

ћы нашли что-то

Ётот список доступа блокирует весь многоадресный трафик. ƒавайте сделаем настройку, котора€ разрешит EIGRP.

OFF2(config)#ip access-list extended BLOCKMULTICAST
OFF2(config-ext-nacl)#5 permit ip any host 224.0.0.10

ћы создаем специальное правило, которое будет разрешать трафик EIGRP.

создаем специальное правило, которое будет разрешать трафик EIGRP

 ак мы видим, что трафик EIGRP разрешен - это соответствует правилу, которое мы выше создали.

трафик EIGRP разрешен трафик EIGRP разрешен

ќба маршрутизатора теперь показывают рабочее соседство EIGRP.

ќба маршрутизатора теперь показывают рабочее соседство EIGRP

Ёхо-запрос, который мы только что отправили, теперь работает.

»звлеченный урок: не блокируйте пакеты EIGRP!

Case #6

сеть Frame Relay и один канал PVC

–ассмотрим очередную ситуацию, в которой нет соседства EIGRP. Ќа картинке выше мы имеем сеть Frame Relay и один канал PVC между OFF1 и OFF2. ¬от соответствующа€ конфигураци€:

соответствующа€ конфигураци€ соответствующа€ конфигураци€

ќба маршрутизатора настроены дл€ Frame Relay, а EIGRP настроен.

ќба маршрутизатора настроены дл€ Frame Relay ќба маршрутизатора настроены дл€ Frame Relay

¬идно, что нет соседей ... это не хорошо! ћожем ли мы пропинговать другую сторону?

ћожем ли мы пропинговать другую сторону

ѕинг проходит, поэтому мы можем предположить, что PVC Frame Relay работает. EIGRP, однако, использует многоадресную передачу, а Frame Relay по умолчанию - NBMA. ћожем ли мы пропинговать адрес многоадресной рассылки EIGRP 224.0.0.10?

PVC Frame Relay работает

«десь нет ответа на наш вопрос, по крайней мере, теперь мы знаем, что unicast трафик работает, а multicast не работает. Frame Relay может быть настроен дл€ point-to-point или point-to-multipoint соединени€. ‘изический интерфейс всегда €вл€етс€ интерфейсом frame-relay point-tomultipoint, и дл€ него требуютс€ frame-relay maps, давайте проверим это:

frame-relay maps frame-relay maps

ћы видим, что оба маршрутизатора имеют DLCI-to-IP карты, поэтому они знают, как св€затьс€ друг с другом. ¬идим, что они используют ключевое слово "статический", а это говорит о том, что это сопоставление было кем-то настроено и не изучено с помощью Inverse ARP (в противном случае вы увидите "динамический"). ћы не видим ключевое слово "broadcast", которое требуетс€ дл€ пересылки широковещательного или многоадресного трафика. Ќа данный момент у нас есть 2 варианта решени€ этой проблемы:

  • Ќастроить EIGRP дл€ использовани€ одноадресного трафика вместо многоадресного.
  • ѕроверить конфигурацию Frame Relay и убедитс€, что многоадресный трафик не перенаправл€етс€.

ƒавайте сначала сделаем unicast настройку EIGRP:

OFF1(config)#router eigrp 12
OFF1(config-router)#neighbor 192.168.12.2 serial 0/0
OFF2(config)#router eigrp 12
OFF2(config-router)#neighbor 192.168.12.1 serial 0/0

Ќам нужна команда neighbor дл€ конфигурации EIGRP.  ак только вы введете эту команду и нажмете enter, вы увидите это:

neighbor neighbor

«адача решена! “еперь давайте попробуем другое решение, где мы отправл€ем multicast трафик по PVC Frame Relay:

OFF1(config)#router eigrp 12
OFF1(config-router)#no neighbor 192.168.12.2 serial 0/0
OFF2(config)#router eigrp 12
OFF2(config-router)#no neighbor 192.168.12.1 serial 0/0

≈сли это не работает ... не исправл€йте это... , но не в этот раз! ѕришло врем€ сбросить соседство EIGRP.

OFF1(config)#interface serial 0/0
OFF1(config-if)#frame-relay map ip 192.168.12.2 102 broadcast
OFF2(config)#interface serial 0/0
OFF2(config-if)#frame-relay map ip 192.168.12.1 201 broadcast

Broadcast - это ключевое волшебное слово здесь. Ёто разрешит широковещательный и многоадресный трафик.

широковещательный и многоадресный трафик широковещательный и многоадресный трафик

ѕосле изменени€ конфигурации frame-relay map по€вл€етс€ соседство EIGRP! Ёто все, что нужно сделать.

»звлеченный урок: проверьте, поддерживает ли ваша сеть Frame Relay broadcast или нет. Ќастройте EIGRP дл€ использовани€ unicast передачи или измените конфигурацию Frame Relay дл€ поддержки широковещательного трафика.

ѕродолжение цикла про поиск и устранение неисправностей протокола EIGRP можно почитать тут.