ѕодпишитесь на наш Telegram-канал Ѕудьте в курсе последних новостей 👇 😉 ѕодписатьс€
ѕоддержим в трудное врем€ —пециальное предложение на техническую поддержку вашей »“ - инфраструктуры силами наших экспертов ѕодобрать тариф
ѕоставка оборудовани€ √аранти€ и помощь с настройкой. —кидка дл€ наших читателей по промокоду WIKIMERIONET  упить
»нтерфейс статистики Merion Mertics показывает ключевые диаграммы и графики по звонкам, а также историю звонков в формате, который легко поймет менеджер ѕопробовать бесплатно
¬недрение
офисной телефонии
Ўаг на пути к созданию доступных унифицированных коммуникаций в вашей компании ¬недрить
»нтеграци€ с CRM ѕомогаем навести пор€док с данными
и хранить их в единой экосистеме
ѕодключить
»“ Ѕезопастность ”мна€ информационна€ безопасность дл€ вашего бизнеса «аказать
ћерион Ќетворкс

13 минут чтени€

≈сть большое количество крупных компании с сетью, содержащих более 500 маршрутизаторов Cisco (и тыс€чи коммутаторов Cisco Catalyst).  акой используетс€ протокол маршрутизации, поддерживающий все эти маршрутизаторы в согласии о доступных маршрутах? Ёто усовершенствованный протокол маршрутизации внутреннего шлюза (EIGRP). »менно этому посв€щена данна€ стать€, котора€ €вл€етс€ первой из серии статей, посв€щенных EIGRP (Enhanced Interior Gateway Routing Protocol).

Ёта сери€ статей рассматривает фундаментальные концепции EIGRP. ¬се статьи из цикла EIGRP:

  1. „асть 1. ѕонимание EIGRP: обзор, базова€ конфигураци€ и проверка
  2. „асть 2. ѕро соседство и метрики EIGRP
  3. „асть 2.2. ”становка K-значений в EIGRP
  4. „асть 3.  онвергенци€ EIGRP Ц настройка таймеров
  5. „асть 4. ѕассивные интерфейсы в EIGRP
  6. „асть 5. Ќастройка статического соседства в EIGRP
  7. „асть 6. EIGRP: идентификатор роутера и требовани€ к соседству

ѕолное руководство по EIGRP в PDF

PDF - это удобно 👾 ¬се статьи из цикла про EIGRP (Enhanced Interior Gateway Routing Protocol) мы свели в единый PDF домкумент, который вы можете скачать и читать в дороге.


ќсновы EIGRP

—уществует давн€€ дискусси€ о фундаментальной природе EIGRP. ѕо своей сути, €вл€етс€ ли EIGRP протоколом маршрутизации состо€ни€ канала или протоколом маршрутизации вектора рассто€ни€? »ли же это гибридный протокол маршрутизации (то есть комбинаци€ того и другого)? ¬ы найдете много литературы, поддерживающей идею о том, что EIGRP €вл€етс€ гибридным протоколом маршрутизации, утвержда€, что соседи EIGRP изначально обмениваютс€ своей полной таблицей маршрутизации, во многом похожей на протокол маршрутизации вектора рассто€ни€, и EIGRP отправл€ет только обновлени€ маршрутизации на основе сетевых изменений, во многом напоминающие протокол маршрутизации состо€ни€ канала.

ћногие сетевые инженеры пришли к убеждению, что EIGRP-это "продвинутый протокол маршрутизации вектора рассто€ни€". »х рассуждени€ по этому поводу: рассмотрим фундаментальную характеристику протокола маршрутизации состо€ни€ канала, котора€ заключаетс€ в том, что маршрутизаторы поддерживают таблицу топологии, указывающую, как маршрутизаторы св€заны между собой. Ёти маршрутизаторы (говор€ о протоколах маршрутизации, таких как OSPF и IS-IS) затем запускают алгоритм ƒейкстры на этой топологии, чтобы определить "кратчайший" путь к целевой сети с точки зрени€ конкретного маршрутизатора. EIGRP не поддерживает представление о топологии сети и не выполн€ет алгоритм ƒейкстры. —корее всего, таблица топологии EIGRP содержит список доступных сетей, а также информацию о "рассто€нии" до этих сетей.


’арактеристики EIGRP

ƒавайте начнем наш обзор EIGRP, рассмотрением нескольких основных характеристиках EIGRP:

  • Ѕыстра€ конвергенци€: если пропадает св€зь в сети, во многих случа€х EIGRP может быстро перенаправить поток данных, обойд€ место сбо€ св€зи. ќбычно это происходит не более чем за 3 секунды. Ёта быстра€ конвергенци€ становитс€ возможной благодар€ тому, что EIGRP имеет резервный маршрут к сети, и этот резервный маршрут готов вз€ть на себ€ управление в случае сбо€ основного маршрута.
  • ¬ысока€ масштабируемость: в то врем€ как протокол маршрутизации, такой как RIP, имеет ограничение в п€тнадцать переходов маршрутизатора, EIGRP может масштабироватьс€ дл€ поддержки очень крупных корпоративных сетей.
  • Ѕалансировка нагрузки с использованием каналов с разной метрикой: по умолчанию и EIGRP, и OSPF балансируют трафик нагрузки по нескольким каналам, ведущим к определенной целевой сети, если стоимость (то есть значение метрики протокола маршрутизации) одинакова. ќднако EIGRP может быть настроен дл€ балансировки нагрузки между каналами с неравными стоимост€ми. Ёто стало возможным благодар€ функции дисперсии.
  • ѕоддержка маски подсети переменной длины (VLSM): в отличие от RIP версии 1, EIGRP отправл€ет информацию о маске подсети как часть объ€влени€ маршрута.
  •  оммуникации через мультикаст: в EIGRP спикер маршрутизатор взаимодействует с другими EIGRP-спикер маршрутизаторами через мультикаст. ¬ частности, EIGRP дл€ IPv4 использует адрес многоадресной рассылки 224.0.0.10, в то врем€ как EIGRP дл€ IPv6 использует адрес многоадресной рассылки ff02::a.
  • Ѕольше не проприетарный протокол: в то врем€ как Cisco первоначально представила EIGRP как Cisco-proprietary протокол маршрутизации, в последние годы EIGRP был открыт дл€ других поставщиков. ¬ частности, EIGRP стал открытым стандартом в 2013 году, а информационный RFC EIGRP (RFC 7868) был опубликован в 2016 году.
  • ѕоддержка нескольких протоколов: EIGRP изначально был разработан дл€ поддержки маршрутизации нескольких протоколов, включа€ IPv4, IPX и AppleTalk. ’от€ современные сети редко используют IPX или AppleTalk, EIGRP теперь может поддерживать IPv6, который набирает попул€рность. ƒанна€ поддержка нескольких протоколов становитс€ возможной благодар€ Protocol-Dependent Modules (PDM), где существует отдельный PDM, обрабатывающий решени€ о маршрутизации дл€ каждого маршрутизируемого протокола (например, IPv4 и IPv6).
  • јлгоритм диффузионного обновлени€ (DUAL): алгоритм EIGRP, используемый дл€ отслеживани€ маршрутов, известных соседним маршрутизаторам. DUAL также используетс€ дл€ определени€ наилучшего пути к целевой сети (то есть к маршруту-преемнику) и любых приемлемых резервных путей к этой целевой сети (то есть к возможным маршрутам-преемникам).
  • —уммирование: чтобы уменьшить количество записей в таблице топологии EIGRP (или таблице IP-маршрутизации маршрутизатора), EIGRP имеет возможность суммировать несколько сетевых объ€влений в одно сетевое объ€вление. Ёто обобщение можно настроить вручную. ќднако EIGRP имеет функцию автоматического суммировани€ маршрутов, котора€ суммирует сети на классовых границах сети.
  • ќбновлени€: полные обновлени€ таблицы топологии EIGRP отправл€ютс€ при обнаружении новых соседей. ¬ противном случае будут отправлены частичные обновлени€.

ќбзор настройки

Ѕазова€ конфигураци€ EIGRP очень проста в настройке. Ќа самом деле, дл€ этого требуетс€ только две команды:

router eigrp asn
network net-id wildcard-mask

 оманда router eigrp asn запускает процесс маршрутизации EIGRP на маршрутизаторе дл€ автономной системы (AS), заданной переменной asn. Ёта команда также переводит вас в режим настройки маршрутизатора. ќттуда вы можете выполнить вторую команду, network net-id wildcard-mask. Ёта втора€ команда использует комбинацию сетевого адреса и маски подсети дл€ указани€ диапазона одного или нескольких IP-адресов, и любой интерфейс маршрутизатора, чей IP-адрес принадлежит этому диапазону IP-адресов, затем участвует в процессе маршрутизации EIGRP. “ем не менее, существуют некоторые правила и модели поведени€, которые следует учитывать при выполнении этих команд:

  • EIGRP-спикер маршрутизаторы должны быть такими же, как и дл€ формировани€ соседства.
  • ѕосле того как маршрутизатор включает EIGRP на интерфейсах, соответствующих команде network EIGRP, он пытаетс€ обнаружить соседей с помощью многоадресной рассылки приветственных сообщений EIGRP.
  • ≈сли в команде network не указана маска подсети, то указанный сетевой адрес должен быть классовым сетевым адресом.
  • ≈сли в команде network не указана маска подсети, а указан классовый сетевой адрес, то все интерфейсы, IP-адреса которых подпадают под классовую сеть (например, 172.16.1.1 /24 подпадает под 172.16.0.0 /16), будут участвовать в процессе маршрутизации EIGRP.

„тобы проиллюстрировать эти пон€ти€, рассмотрим следующий пример:

топологи€ EIGRP

 онфигураци€ EIGRP на маршрутизаторах OFF1, OFF2 и OFF3

! Router OFF1
router eigrp 1
network 10.1.1.0 0.0.0.«
network 10.1.1.5 0.0.0.0
network 192.0.2.0
! Router OFF2
router eigrp 1
network 10.0.0.0
network 198.51.100.0
! Router OFF«
router eigrp 1
network 0.0.0.0

 онфигураци€ EIGRP на маршрутизаторах OFF1, OFF2 и OFF3 начинаетс€ с команды router eigrp 1. Ёта команда говорит каждому маршрутизатору начать процесс маршрутизации EIGRP в автономной системе 1. ѕоскольку номера автономной системы должны совпадать между EIGRP-спикер-сосед€ми, все три маршрутизатора используют один и тот же номер автономной системы 1.  роме того, обратите внимание, как мен€етс€ конфигураци€ при использовании команды network:


 оманда network 10.1.1.0 0.0.0.3 на роутере OFF1

Ќа маршрутизаторе OFF1 команда network 10.1.1.0 0.0.0.3 задает сетевой адрес 10.1.1.0 с обратной маской 0.0.0.3, котора€ соответствует 30-битной маске подсети (то есть маске подсети 255.255.255.252). ѕоскольку IP-адрес интерфейса Gig 0/1 маршрутизатора OFF1 10.1.1.1 / 30 попадает в эту подсеть, этот интерфейс проинструктирован участвовать в процессе EIGRP.


 оманда network 10.1.1.5 0.0.0.0 на роутере OFF1

 оманда network 10.1.1.5 0.0.0.0 указывает конкретный IP-адрес, а не всю подсеть (или можно утверждать, что это подсеть, содержаща€ один IP-адрес). ћы знаем, что он указывает только один IP-адрес из-за маски подсети 0.0.0.0. Ќапомним, что в маске подсети мы имеем р€д непрерывных нулей, за которыми следует р€д непрерывных единиц (в двоичном коде). ƒвоичные нули соответствуют позиции битов в IP-адресе, определ€ющие адрес сети, а бинарные единицы соответствуют позиции битов в IP-адресе, который указывает адрес узла. ќднако в том случае, когда у нас все нули, как в нашем случае, у нас есть сеть с одним и только одним IP-адресом (то есть маска подсети равна /32). ѕоскольку IP-адрес совпадает с IP-адресом интерфейса Gig 0/2 маршрутизатора OFF1, этот интерфейс также участвует в процессе маршрутизации EIGRP.


 оманда network 192.0.2.0 на роутере OFF1

ѕоследн€€ команда network на маршрутизаторе OFF1 - это network 192.0.2.0. »нтересно, что эта команда фактически была введена как сеть 192.0.2.0 0.0.0.255, но поскольку 0.0.0.255 €вл€етс€ обратной маской, соответствующей маске подсети по умолчанию сети класса C (в данном случае 192.0.2.0 /24), она подразумеваетс€, но не показываетс€. IP-адрес интерфейса Gig 0/3 маршрутизатора OFF1 192.0.2.1 / 24 действительно попадает в подсеть класса C, заданную командой network. “аким образом, Gig 0/3 также начинает участвовать в процессе маршрутизации EIGRP маршрутизатора OFF1.


 оманда network 10.0.0.0 на роутере OFF2

 оманда network 10.0.0.0 на маршрутизаторе OFF2, не имеет обратной маски. ќднако помните, что из ранее обсуждавшейс€ команды network (на маршрутизаторе OFF1) обратна€ маска подсети не отображаетс€, если она отражает естественную маску заданной подсети. ќсновыва€сь на этой логике, мы можем заключить, что если мы намеренно опустим аргумент обратной маски из команды network, то предполагаема€ обратна€ маска будет маской подсети, соответствующей классовой маске подсети сети, указанной в команде network. ¬ этом случае первый октет сети, указанный в команде network address, равен 10. 10 в первом октете адреса указывает, что мы имеем дело с адресом класса ј, который имеет маску подсети по умолчанию 255.0.0.0 и, следовательно, обратную маску по умолчанию 0.0.0.255. ѕоскольку интерфейсы Gig 0/1 и Gig 0/2 маршрутизатора OFF2 подпадают под этот классовый сетевой оператор, оба интерфейса участвуют в процессе маршрутизации EIGRP маршрутизатора OFF2.


 оманда network 198.51.100.0 на роутере OFF2

 ак и предыдуща€ команда network, команда маршрутизатора OFF2 network 198.51.100.0 была введена без указани€ обратной маски. ѕоскольку первый октет адреса равен 198, мы можем заключить, что у нас есть сеть класса C, чь€ маска подсети по умолчанию равна 255.255.255.0, а обратна€ маска по умолчанию равна 0.0.0.255. IP-адрес (198.51.100.1 /24) интерфейсного Gig 0/3 на маршрутизаторе OFF2 живет в пределах указанной подсети 198.51.100.0 /24. “аким образом, интерфейс участвует в процессе маршрутизации EIGRP.


 оманда network 0.0.0.0 на роутере OFF3

Ќапомним, что оператор network EIGRP, вопреки распространенному мнению, не указывает сеть дл€ объ€влени€. —корее, он определ€ет диапазон одного или нескольких IP-адресов, и любой интерфейс с IP-адресом в этом диапазоне проинструктирован участвовать в процессе маршрутизации EIGRP. Ёто означает, что, если мы хотим, чтобы все интерфейсы на маршрутизаторе участвовали в одном и том же процессе маршрутизации EIGRP, мы могли бы дать команду network 0.0.0.0, чтобы указать все возможные IP-адреса. ѕоскольку IP-адрес каждого отдельного интерфейса подпадает под категорию "все возможные IP-адреса", все интерфейсы на маршрутизаторе OFF3 проинструктированы участвовать в процессе маршрутизации EIGRP.  роме того, сетевые адреса этих участвующих интерфейсов (вместе с информацией о подсети дл€ этих сетевых адресов) затем объ€вл€ютс€ через EIGRP.


ѕроверка

ѕроцесс проверки EIGRP - это нечто большее, чем просто проверка того, что между всеми маршрутизаторами сформировались соседские отношени€ и что все маршрутизаторы изучили все маршруты в сети. ѕроцесс верификации должен помочь нам убедитьс€ в том, что наши изначальные требовани€ были выполнены. Ќапример, нам нужно найти соответствующие маршруты, определенные интерфейсы и конкретных соседей, которые будут отображатьс€ в таблицах EIGRP.  ак только определимс€ с нашими изначальными цел€ми проектировани€ и ожидаемыми результатами, мы можем применить команды проверки EIGRP, показанные в таблице ниже:


 лючевые команды проверки EIGRP

 лючевые команды проверки EIGRP

¬ следующих примерах показаны результаты выполнени€ каждой из этих команд после их выполнени€ на маршрутизаторе OFF1, показанном в предыдущей топологии.

¬ывод результатов команды show ip route на маршрутизаторе OFF1:

¬ывод результатов команды show ip route на маршрутизаторе OFF1

ќбратите внимание, как маршруты, изученные с помощью EIGRP, показаны с литерой D в левом столбце. Ётот код D указывает на маршрут, изученный через EIGRP. Ёти маршруты включают 10.1.1.8/30, 198.51.100.0/24 и 203.0.113.0 /24. “акже обратите внимание на выделенные числовые значени€ 90 в каждом EIGRP-изученном маршруте. 90 - это административное рассто€ние EIGRP (то есть его правдоподобность по сравнению с другими источниками маршрутизации), где более низкие значени€ административного рассто€ни€ предпочтительны по сравнению с более высокими значени€ми.

¬ывод из команды show ip protocols на маршрутизаторе OFF1

show ip protocols на маршрутизаторе OFF1

¬ывод информации команды show ip protocols на EIGRP-спикер маршрутизаторе, как видно выше, предлагает нам несколько точек данных. Ќапример, в разделе Routing for Networks: вы видите список сетей, указанных командой network в режиме конфигурации EIGRP. ¬ разделе Routing Information Sources: вы можете видеть IP-адреса соседей EIGRP, которые €вл€ютс€ 10.1.1.2 (то есть маршрутизатором OFF2) и 10.1.1.6 (то есть маршрутизатором OFF3) нашей топологии. “акже в этом разделе вы можете увидеть административное рассто€ние (AD) до наших соседей. ѕоскольку эти соседи €вл€ютс€ EIGRP-спикер маршрутизаторами, у них есть EIGRP AD по умолчанию 90. Ќаконец, обратите внимание на метрический вес K1=1, K2=0, K3=1, K4=0, K5=0 части выходного сигнала. ¬ следующей статье мы узнаем, как EIGRP вычисл€ет свою метрику и как этот расчет включает в себ€ K-значени€.

¬ывод из команды show ip eigrp interfaces на маршрутизаторе OFF1

show ip eigrp interfaces на маршрутизаторе OFF1

¬ыходные данные show ip eigrp interfaces, рассмотренные выше, указывают на то, что Gig 0/1, Gig 0/2 и Gig 0/3 маршрутизатора OFF1 участвуют в процессе маршрутизации EIGRP. ¬ частности, этот процесс предназначен дл€ EIGRP AS 1. “акже обратите внимание, что соседство EIGRP было установлено с другим маршрутизатором, подключенным от интерфейса Gig 0/1 маршрутизатора OFF1, и другим от интерфейса Gig 0/2. ƒоказательством этих соседских отношений €вл€етс€ наличие числа, превышающего 0 в колонке Peers. ѕоскольку интерфейс Gig 0/3 маршрутизатора OFF1 не формировал соседство с любыми другими маршрутизаторами, говор€щими на EIGRP, в его столбце Peers стоит 0.

¬ывод из команды show ip eigrp neighbors на маршрутизаторе OFF1:

show ip eigrp neighbors на маршрутизаторе OFF1

¬ то врем€ как выводимые данные из команды show ip eigrp interfaces указывали, что у нас было несколько соседей EIGRP, выходные данные из команды show ip eigrp neighbors, как видно выше, предлагают более подробную информацию об этих сосед€х. ¬ частности, сосед, св€занный с интерфейсом маршрутизатора OFF1 по Gig 0/1, имеет IP-адрес 10.1.1.2, а сосед соединен с интерфейсом маршрутизатора OFF1 по Gig0/2 имеет IP-адрес 10.1.1.6.

¬ывод из команды show ip eigrp topology [all-links] на маршрутизаторе OFF1:

show ip eigrp topology [all-links] на маршрутизаторе OFF1

ќдной из наиболее распространенных команд, используемых дл€ проверки EIGRP и устранени€ неполадок, €вл€етс€ show ip eigrp topology, как показано в приведенном выше примере. ¬ыходные данные этой команды показывают маршруты-преемники (то есть предпочтительные маршруты) и возможные маршруты-преемники (то есть резервные маршруты), известные процессу маршрутизации EIGRP. ѕожалуйста, имейте в виду, что по€вление маршрута в таблице топологии EIGRP не гарантирует его присутстви€ в таблице IP-маршрутизации маршрутизатора. ¬ частности, маршруты-преемники, присутствующие в таблице топологии EIGRP, €вл€ютс€ только кандидатами дл€ попадани€ в таблицу IP-маршрутизации маршрутизатора. Ќапример, маршрутизатор может обладать более достоверной информацией о маршрутизации дл€ сети, такой как статически настроенный маршрут с административным рассто€нием 1. ≈сли EIGRP действительно €вл€етс€ наиболее правдоподобным источником маршрутизации дл€ конкретной сети, то эта сеть будет введена в таблицу IP-маршрутизации маршрутизатора.  роме того, обратите внимание, как добавление аргумента all-links в приведенном выше примере показывает еще больше маршрутов (они выделены). –азница заключаетс€ в том, что аргумент all-links предписывает команде show ip eigrp topology отображать все изученные EIGRP маршруты, даже если некоторые из маршрутов не считаютс€ маршрутами-преемниками или возможными маршрутами-преемниками.

“еперь, когда вы знаете базу, почитайте про соседство и метрики EIGRP