ѕодпишитесь на наш Telegram-канал Ѕудьте в курсе последних новостей 👇 😉 ѕодписатьс€
ѕоддержим в трудное врем€ —пециальное предложение на техническую поддержку вашей »“ - инфраструктуры силами наших экспертов ѕодобрать тариф
ѕоставка оборудовани€ √аранти€ и помощь с настройкой. —кидка дл€ наших читателей по промокоду WIKIMERIONET  упить
»нтерфейс статистики Merion Mertics показывает ключевые диаграммы и графики по звонкам, а также историю звонков в формате, который легко поймет менеджер ѕопробовать бесплатно
¬недрение
офисной телефонии
Ўаг на пути к созданию доступных унифицированных коммуникаций в вашей компании ¬недрить
»нтеграци€ с CRM ѕомогаем навести пор€док с данными
и хранить их в единой экосистеме
ѕодключить
»“ Ѕезопасность ”мна€ информационна€ безопасность дл€ вашего бизнеса «аказать

“раблшутинг OSPF

„асть 2. ѕоиск и устранение проблем

ћерион Ќетворкс

10 минут чтени€

ѕочитайте первую часть статьи.
“опологи€

ѕерва€ проблема. ƒва роутера работают с одной областью OSPF, и каждый роутер имеет loopback интерфейс, объ€вленный в OSPF. ¬от вывод таблиц маршрутизации:

show ip route show ip route

 ак мы можем наблюдать, что роутер R1 узнал о сети 10.2.2.0/24 от роутера R2, но в таблице маршрутизации роутера R2 пусто. „то не так?

show ip ospf interface loopback 0 show ip ospf interface loopback 0

¬идно, что OSPF не включен на интерфейсе loopback0 роутера R1, так что же мы тогда объ€вл€ем в сет€х?

show ip protocols | begin Networks

ѕохоже, мы объ€вл€ем сеть 10.10.1.0/24, но эта сеть не настроена ни на одном интерфейсе... —еть 10.1.1.0/24 настроена на интерфейсе loopback0 роутера R1.

show run | section router ospf

«десь вы видите неправильно введенную команду network. ”далим ее.

R1(config)#router ospf 1
R1(config-router)#no network 10.10.1.1 0.0.0.0 area 0
R1(config-router)#network 10.1.1.0 0.0.0.255 area 0

ƒавайте удостоверимс€, что команда network настроена правильно.

show ip route | include 10.1.1.

ѕроблема устранена! Ёта проблема может показатьс€ не серьезной, но использование неправильных сетевых операторов - это то, что происходит посто€нно. ќсобенно если мы используем меньшие подсети (например, /27 или /28 или аналогичные), люди склонны делать ошибки с обратными маскам.

»тог урока: убедитесь, что вы настроили правильный сетевой адрес, обратную маску и область.

”рок є2

“опологи€

ќчередна€ возможна€ ситуаци€. ќп€ть два роутера, но друга€ проблема. ¬от таблицы маршрутизации:

show ip route show ip route

¬ очередной раз роутер R2 не увидел сеть 10.1.1.0/24. „то интересно, что роутер R1 не имеет сети 10.1.1.0/24 в своей таблице маршрутизации как непосредственно подключенной.

show ip protocols | begin Networks

ћы можем проверить, что роутер R1 использует правильную настройку команды network. ѕоскольку R1 даже не имеет сети в своей таблице маршрутизации, предположим, что проблема с интерфейсом.

show ip interface brief

 ажетс€, кто-то забыл применить команду "no shutdown" на интерфейсе.

R1(config)#interface loopback 0
R1(config-if)#no shutdown

ƒавайте включим интерфейс.

show ip route | include 10.1.1.
» теперь он по€вл€етс€ в таблице маршрутизации роутера R2. »тог урока: нельз€ объ€вл€ть то, чего у теб€ нет!

”рок є3

“опологи€

Ќовый урок! ќдна область, оп€ть два роутера... мы хотели бы иметь "full connectivity", но не работает OSPF ... вот вывод таблиц маршрутизации:

show ip route ospf show ip route ospf

–оутер R1 не показывает никаких маршрутов OSPF, R2 показывает ... Ќеобходимо вы€снить, что не так:

show ip protocols

Ѕыстро взгл€нем на роутер R2, чтобы убедитьс€, что он действительно объ€вл€ет правильную сеть(и). ƒа это так и есть.

show ip protocols

¬ывод роутера R1 более интересен ... видно, что у него настроен distribute-list.

show access-lists

¬ этом заключаетс€ наша проблема. ƒавайте удалим distribute-list.

R1(config)#router ospf 1
R1(config-router)#no distribute-list 1 in

Ёта команда отключит его.

show ip route ospf
«адача решена! »тог урока: знать о distribute-list, запрещающий объ€вление и / или установку префиксов в таблице маршрутизации.

”рок є4

“опологи€

¬згл€нем на более сложные проблемы OSPF. Ќа изображении выше мы имеем роутер R1 и роутер R2, но на этот раз мы имеем конфигурацию OSPF с несколькими област€ми. ¬от конфигураци€ OSPF этих роутеров:

show run | section router ospf show run | section ospf

¬идно, что все сети были объ€влены. ќбласть 2 не св€зана напр€мую с областью 0, поэтому была создана виртуальна€ св€зь.

show ip route show ip route

–оутер R1, однако, не увидел сеть 2.2.2.0/24 от роутера R2, но роутер R2 увидел сеть 1.1.1.0/24. Ћучше всего начать с виртуальной линии здесь:

show ip ospf virtual-links show ip ospf virtual-links

’м, это выгл€дит не очень хорошо. ¬иртуальна€ св€зь отключена. ќбратите внимание на IP-адреса, которые мы видим здесь, это IP-адреса, настроенные на интерфейсах FastEthernet обоих маршрутизаторов.

show ip ospf neighbor show ip ospf neighbor

¬с€кий раз, когда мы настраиваем виртуальное соединение, нам нужно настроить идентификатор маршрутизатора OSPF другой стороны, а не IP-адрес другой стороны!

show run | incl virtual-link show run | incl virtual-link

¬от ошибка, так что давайте исправим ее.

R1(config)#router ospf 1
R1(config-router)#no area 12 virtual-link 192.168.12.2
R1(config-router)#area 12 virtual-link 2.2.2.2

R2(config)#router ospf 1
R2(config-router)#no area 12 virtual-link 192.168.12.1
R2(config-router)#area 12 virtual-link 1.1.1.1

¬от так должна выгл€деть virtual-link, настроенна€ между идентификаторами маршрутизаторов OSPF.

так должна выгл€деть virtual-link так должна выгл€деть virtual-link

—разу после ввода правильных команд по€в€тс€ данные сообщени€ в консоли.

show ip route ospf

«апись OSPF дл€ сети 2.2.2.0/24 по€вилась.


”рок є5

“опологи€

ƒруга€ проблема. “е же роутеры, но по€вилс€ "домен внешней маршрутизации". Ёто может быть другой протокол маршрутизации, такой как RIP или EIGRP, который мы будем распростран€ть в OSPF. R2 перераспредел€ет сеть 2.2.2.0 / 24 в OSPF, но по какой-то причине она не отображаетс€ на R1. „тобы было интересно, мы не будем просматривать конфигурацию OSPF на роутерах.

show ip route

Ќет сети 2.2.2.0/24 на роутере R1, поэтому давайте изучим роутер R2.

show ip route | include 2.2.2.

 ак мы можем видеть, сеть находитс€ в таблице маршрутизации роутера R2 как directly connected.

show ip protocols

 ак мы можем видеть роутер R2 был настроен дл€ перераспределени€ напр€мую подключенных сетей. Ёто должно включать сеть 2.2.2.0/24 на интерфейса loopback0.

show ip ospf database external

ќднако в базе данных OSPF пусто? „то может быть причиной этого? ¬озможно, вы помните правила различных типов областей OSPF. ƒавайте вы€сним, что это за область!

show ip protocols | include areas

¬от и объ€снение, это stub area! Stub area не допускают LSA type 5 (внешние маршруты). ћы можем либо превратить эту область в normal area или NSSA. ƒавайте переведем в NSSA.

R1(config)#router ospf 1
R1(config-router)#no area 12 stub
R1(config-router)#area 12 nssa

R2(config)#router ospf 1
R2(config-router)#no area 12 stub
R2(config-router)#area 12 nssa

»зменим тип области на обоих маршрутизаторах. ќбласть NSSA допускает внешние маршруты с помощью LSA type 7.

show ip ospf database nssa-external

Ќаша сеть 2.2.2.0 / 24 теперь в базе данных OSPF маршрутизатора R2.

show ip route | include 2.2.2.

»тог урока: Stub area не допускают внешних префиксов (LSA Type 5). Ћибо измените область на NSSA, либо прекратите перераспределение.


”рок є6

“опологи€

ќчередна€ проблема. ѕроблема default route OSPF. Ќа рисунке имеютс€ роутер R1 и роутер R2, и сеть 192.168.12.0 /24 объ€вленна€ в OSPF. Loopback интерфейсы роутера R2 не объ€вл€етс€ в OSPF, но мы используем default route, чтобы роутер R1 мог добратьс€ до них. «десь представлены конфигурации OSPF:

show run | section router ospf show run | section router ospf

¬идно, что в выводе роутера R2 присутствует команда default-information originate дл€ объ€влени€ default route.

show ip route

”вы, но мы не видим default route на роутере R1. Ѕудем искать неполадки в настройке. ƒавайте проверим роутер R2:

show ip route

¬ таблице маршрутизации роутера R2 не виден default route. „тобы OSPF объ€вл€л default route, можно использовать два варианта:

  • ”бедитесь, что у вас есть default route в routing table (невозможно объ€вл€ть то, чего нет);
  • ѕримените команду default-information originate always. ќна объ€вит default route, даже если он не прописан.
R2(config)#ip route 0.0.0.0 0.0.0.0 null 0

¬ыше первый метод решени€ проблемы. ћы создадим default route на роутере R2. ќбычно указываетс€ default route на ISP роутере, но сейчас другого роутера нет. ћы укажем default route дл€ интерфейса null0, и он будет внесен в routing table.

show ip route ospf

ѕравило работает!

R2(config)#no ip route 0.0.0.0 0.0.0.0 null 0
R2(config)#router ospf 1
R2(config-router)#default-information originate always
show ip route ospf

»тог урока: что бы объ€вить default route с помощью OSPF, вам нужно иметь default route в таблице маршрутизации или использовать ключевое слово "always".


”рок є7

“опологи€

Ќемного сложнее проблема... те же два роутера , все в зоне 0. ¬от настройки OSPF:

show run | section router ospf show run | section router ospf

Ќичего особенного, все сети объ€влены, и мы используем одну область.

show ip route show ip route

”вы ... таблицы маршрутизации пусты! ѕо крайней мере, никакой отсутствует информаци€ о OSPF ... Ќастройки network выгл€д€т хорошо, так что это хороший момент вникнуть поглубже в OSPF LSDB. ƒавайте сначала проверим идентификаторы маршрутизатора OSPF:

show ip ospf neighbor show ip ospf neighbor

«десь мы видим OSPF router ID. ≈сли вы внимательно посмотрите на информацию выше, вы заметите что-то необычное. State full, но роутер R1 не выбрал DR / BDR, а роутер R2 выбрал роутер R1 в качестве BDR.

show ip ospf database router

ћы можем использовать команду show ip ospf database router дл€ поиска информации от определенного соседа OSPF. –оутер R1 говорит нам, adv router is not-reachable. Ёто плохо.

show ip ospf database router

–оутер R2 также сообщает нам, что роутер R1 недоступен, и если вы посмотрите внимательно, то увидите, что он видит св€зь как point-to-point. ћы не видим этого в выводе на роутере R1. Ёто, веро€тно, означает, что роутер R1 и роутер R2 используют другой тип сети OSPF, что приводит к разнице в LSDB. Ёто не позволит нашим роутерам устанавливать маршруты в таблицу маршрутизации!

show ip ospf interface fastEthernet 0/0 | include Network Type show ip ospf interface fastEthernet 0/0 | include Network Type

“еперь мы кое-что вы€снили. “ип сети отличаетс€ ... широковещательна€ передача на роутере R2 и точка-точка на роутере R1. Ќам действительно удалось установить соседство OSPF с этим, но возникает разница в LSDB.

ѕроизведем исправлени€.

R1(config)#interface fa0/0
R1(config-if)#ip ospf network broadcast

»зменение типа сети на роутере R1 сделает свое дело.

show ip route ospf show ip route ospf

Ќаконец "ќ" по€вл€етс€ в наших таблицах маршрутизации...проблема решена!

»тог урока: убедитесь, что вы используете правильный тип сети OSPF на обоих роутерах.

”рок є8

“опологи€

ќчередна€ внештатна€ ситуаци€. OSPF настроено между роутерами R1 и R2, но не все сети объ€влены. Loopback интерфейсы роутера R2 перераспредел€ютс€ в OSPF. ¬от настройки обоих роутеров:

show run | section router ospf show run | section router ospf

ћы наблюдаем команду redistribute connected на роутере R2, котора€ должна перераспределить сети на интерфейсах обратной св€зи в OSPF.

show ip route

ќднако здесь ничего нет ...

show ip protocols | include filter show ip protocols | include filter

ќбычно было бы неплохо проверить, есть ли distribute list или нет.

show run | include redistribute

 люч к решению этой проблемы - эта команда. ≈сли вы наберете redistribute connected OSPF будет распростран€ть только classful networks.

R2(config)#router ospf 1
R2(config-router)#redistribute connected subnets

Ќам нужно добавить параметр "subnets", позвол€ющий заставить его выполн€ть redistribute subnet основных сетей.

show ip route ospf

Ќу вот, наша маршрутна€ таблица заполнена.

»тог урока: добавьте параметр " subnets " при использовании перераспределени€ или перераспредел€ютс€ только classful networks.