ѕодпишитесь на наш Telegram-канал Ѕудьте в курсе последних новостей 👇 😉 ѕодписатьс€
ѕоддержим в трудное врем€ —пециальное предложение на техническую поддержку вашей »“ - инфраструктуры силами наших экспертов ѕодобрать тариф
ѕоставка оборудовани€ √аранти€ и помощь с настройкой. —кидка дл€ наших читателей по промокоду WIKIMERIONET  упить
»нтерфейс статистики Merion Mertics показывает ключевые диаграммы и графики по звонкам, а также историю звонков в формате, который легко поймет менеджер ѕопробовать бесплатно
¬недрение
офисной телефонии
Ўаг на пути к созданию доступных унифицированных коммуникаций в вашей компании ¬недрить
»нтеграци€ с CRM ѕомогаем навести пор€док с данными
и хранить их в единой экосистеме
ѕодключить
»“ Ѕезопасность ”мна€ информационна€ безопасность дл€ вашего бизнеса «аказать
ћерион Ќетворкс

6 минут чтени€

BGP - это сложный протокол маршрутизации, и бывают ситуации, когда что-то идет не так как надо.  роме того, что он сложный, он также совершенно отличаетс€ от наших IGP протоколов (OSPF и EIGRP). ¬ этой статье мы начнем с рассмотрени€ неполадок, возникающих в установлении соседства BGP, и как только это разберем, перейдем к проблемам с объ€влением маршрутов, которые должны или не должны по€вл€тьс€!


”рок 1

“опологи€

Ќачнем с нескольких простых сценариев. ƒва маршрутизатора BGP, которые подключены и настроены дл€ EBGP.   сожалению, мы видим это, когда провер€ем соседство BGP:

show ip bgp summary show ip bgp summary

 огда два маршрутизатора EBGP, которые напр€мую подключены, не образуют рабочее соседство BGP, может произойти р€д ошибок:

  • Layer 2 не позвол€ет нам добратьс€ до другой стороны.
  • ѕроблема уровн€ 3: неправильный IP-адрес на одном из маршрутизаторов.
  • —писок доступа, блокирующий TCP-порт 179 (BGP).
  • Ќеправильный IP-адрес настроен дл€ соседнего маршрутизатора BGP

ћы можем использовать команду show ip bgp summary, чтобы проверить IP-адреса маршрутизаторов. ќни, совпадают.

выполним эхо Ц запрос

ћы выполним эхо запрос, с помощью команды ping. ¬идим, что, пакеты не могут добратьс€ до другой стороны.

show ip int brief show ip int brief

ѕровер€ем интерфейсы и видим, что кто-то ввел команду отключени€ интерфейса.

R2(config)#interface fa0/0
R2(config-if)#no shutdown

"ѕоднимаем" интерфейс

ѕоднимаем интерфейс ѕоднимаем интерфейс

Ёто прекрасно! Ќаше соседство BGP установлено. Ёто было легко!

»тог урока: убедитесь, что ваш интерфейс работает.

”рок 2

“опологи€

—ледующа€ неполадка похожа на предыдущую, но немного отличаетс€. ћы используем те же маршрутизаторы и номера AS, но на этот раз необходимо установить соседство BGP между интерфейсами обратной св€зи.

ѕосмотрим, как выгл€дит конфигураци€ BGP:

show run | section bgp show run | section bgp

¬от конфигураци€ BGP.  ак вы видите, мы используем loopback интерфейсы дл€ установлени€ соседства BGP-соседей.

show ip bgp summary show ip bgp summary

ќба маршрутизатора показывают, что их сосед BGP бездействует. ≈сть р€д вещей, которые мы должны проверить здесь:

  • ƒоступен ли IP-адрес соседа BGP? ћы не используем пр€мые линии св€зи, поэтому у нас могут возникнуть проблемы с маршрутизацией.
  • TTL IP-пакетов, которые мы используем дл€ внешнего BGP, равен 1. Ёто работает дл€ сетей с пр€мым подключением, но, если они не подключены напр€мую, нам нужно изменить эту настройку.
  • ѕо умолчанию BGP будет получать обновлени€ с IP-адреса, ближайшего к соседу BGP. ¬ нашем примере это интерфейс FastEthernet. Ёто то, что мы должны изменить.
show ip route show ip route

Ќачнем с маршрутизации. ќба маршрутизатора знают только о своих напр€мую подключенных сет€х. „тобы достичь loopback интерфейсов друг друга, мы будем использовать статическую маршрутизацию.

R1(config)#ip route 2.2.2.2 255.255.255.255 192.168.12.2
R2(config)#ip route 1.1.1.1 255.255.255.255 192.168.12.1

ƒва статических маршрута должны выполнить эту работу.

ќтправка ping на IP-адрес 2.2.2.2

ќтправка ping на IP-адрес 2.2.2.2 и получение его из нашего собственного loopback интерфейса доказывает, что оба маршрутизатора знают, как св€затьс€ с loopback интерфейсом друг друга.

R1(config-router)#neighbor 2.2.2.2 ebgp-multihop 2
R2(config-router)#neighbor 1.1.1.1 ebgp-multihop 2

 оманда ebgp-multihop измен€ет TTL на 2.

debug ip bgp debug ip bgp

ћы можем включить отладку, чтобы увидеть прогресс. ясно видно, что R2 использует IP-адрес 192.168.12.2, а R1 отказываетс€ от соединени€.

R1(config-router)#neighbor 2.2.2.2 update-source loopback 0
R2(config-router)#neighbor 1.1.1.1 update-source loopback 0

»спользуйте команду update-source, чтобы изменить IP-адрес источника дл€ обновлений BGP.

—оседство BGP работает —оседство BGP работает

—оседство BGP работает!

»тог урока: маршрутизаторам BGP не требуетс€ устанавливать соседство с использованием напр€мую подключенных интерфейсов. ”бедитесь, что маршрутизаторы BGP могут св€затьс€ друг с другом, что пакеты BGP получены из правильного интерфейса, и в случае EBGP не забудьте использовать команду multihop.

”рок 3

“опологи€ є3

ѕродолжим рассмотрение некоторых проблем IBGP. ƒва маршрутизатора в одной AS и вот конфигураци€:

show run | section bgp show run | section bgp

Ћегко и просто. ћаршрутизаторы используют напр€мую подключенные IP-адреса дл€ соседства BGP.

show ip bgp summary show ip bgp summary

∆аль ... мы не становимс€ сосед€ми. „то может быть не так? ћы используем напр€мую подключенные интерфейсы, поэтому не так много проблем, если не считать проблемы L2 / L2.

ќтправка пинга с одного маршрутизатора на другой

ќтправка пинга с одного маршрутизатора на другой доказывает, что L2 и L3 работают нормально.  ак насчет L3? ” нас могут быть проблемы с транспортным уровнем.

telnet проверка telnet проверка

я не могу подключитьс€ к TCP-порту 179 с обоих маршрутизаторов. Ёто звоночек в сторону того, что что-то блокирует BGP?

show ip interface fastEthernet 0/0 | include access show ip interface fastEthernet 0/0 | include access

¬от оно! Ёто —лужба безопасности.Е

show ip access-lists

 то-то решил, что было бы неплохо "обезопасить" BGP и заблокировать его списком доступа.

R2(config)#interface fastEthernet 0/0
R2(config-if)#no ip access-group 100 in

”далим список доступа.

не блокируйте TCP-порт BGP 179 не блокируйте TCP-порт BGP 179
»тог урока: не блокируйте TCP-порт BGP 179.

”рок 4

“опологи€ є4

—ледующа€ проблема IBGP. Ёто похоже на ситуацию с EBGP ранее...мы будем использовать loopback-интерфейсы дл€ установлени€ соседства BGP, вот конфигурации:

show run | section router bgp show run | section router bgp

Ќичего особенного, IBGP и мы используем loopback интерфейсы.

show ip bgp summary | begin Neighbor show ip bgp summary | begin Neighbor

Ќе повезло здесь ... нет соседей. ƒавайте сначала проверим, могут ли маршрутизаторы получить доступ к loopback интерфейсам друг друга:

show ip route show ip route

Ѕыстрый взгл€д на таблицу маршрутизации показывает нам, что это не так. ћы могли бы исправить это с помощью статического маршрута или IGP. ќбычно мы используем IGP дл€ IBGP дл€ объ€влени€ loopback интерфейсов. —ейчас будем использовать OSPF:

R1(config)#router ospf 1
R1(config-router)#network 1.1.1.0 0.0.0.255 area 0
R1(config-router)#network 192.168.12.0 0.0.0.255 area 0
R2(config)#router ospf 1
R2(config-router)#network 192.168.12.0 0.0.0.255 area 0
R2(config-router)#network 2.2.2.0 0.0.0.255 area 0

Ќабор правильных команд OSPF должно сделать свою работу!

ќтправка эхо-запроса

ќтправка эхо-запроса, чтобы проверить, знают ли маршрутизаторы и как св€затьс€ с сет€ми друг друга, успешен.

show ip bgp summary | begin Neighbor show ip bgp summary | begin Neighbor

“ем не менее, соседство BGP по-прежнему отсутствует

debug ip bgp debug ip bgp

ќтладка показывает, что в соединении отказано, а также показывает локальный IP-адрес, который используетс€ дл€ BGP.  ажетс€, кто-то забыл добавить команду update-source, так что давайте исправим это!

R1(config)#router bgp 1
R1(config-router)#neighbor 2.2.2.2 update-source loopback 0
R2(config)#router bgp 1
R2(config-router)#neighbor 1.1.1.1 update-source loopback 0

“очно так же, как EBGP, мы должны установить правильный источник дл€ наших пакетов BGP.

«адача решена «адача решена

«адача решена! ≈динственное отличие от EBGP в том, что нам не нужно мен€ть TTL с помощью команды ebgp-multihop.

»тог урока: распространенна€ практика настройки IBGP между loopback интерфейсами. ”бедитесь, что эти loopback доступны и обновлени€ BGP получены из loopback интерфейса.

“еперь, рекомендуем почитать вторую часть статьи по траблшутингу протокола BGP.